<!DOCTYPE html> <!--[if IE 7]><html class="ie ie7" lang="en-US"> <![endif]--> <!--[if IE 8]><html class="ie ie8" lang="en-US"> <![endif]--> <!--[if !(IE 7) | !(IE 8)  ]><!--><html lang="en-US"> <!--<![endif]--><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="http://gmpg.org/xfn/11"><link rel="pingback" href="https://www.mpdigest.com/xmlrpc.php"> <!-- Retina Logo--> <style type="text/css" > @media only screen and (-webkit-min-device-pixel-ratio: 2),(min-resolution: 192dpi) {
 /* Retina Logo */
 .primary-logo{background:url(https://www.mpdigest.com/wp-content/uploads/2016/01/MPD-Logo-Retina-2019.png) no-repeat center; display:inline-block !important; background-size:contain;}
 .primary-logo img{ opacity:0; visibility:hidden}
 .primary-logo *{display:inline-block}
 } </style><meta property="og:image" content=""/><meta property="og:title" content="RF Signal Chain Discourse — Part 2: Essential Building Blocks"/><meta property="og:url" content="https://www.mpdigest.com/2021/09/27/rf-signal-chain-discourse-part-2-essential-building-blocks/"/><meta property="og:site_name" content="Microwave Product Digest"/><meta property="og:type" content="article"/><meta property="og:description" content="
by Anton Patyuchenko, Field Applications Engineer, Analog "/><meta property="fb:app_id" content="" /> <!--Meta for twitter--><meta name="twitter:card" value="summary" /><meta name="twitter:site" content="@Microwave Product Digest" /><meta name="twitter:title" content="RF Signal Chain Discourse — Part 2: Essential Building Blocks" /><meta name="twitter:description" content="
by Anton Patyuchenko, Field Applications Engineer, Analog " /><meta name="twitter:image" content="" /><meta name="twitter:url" content="https://www.mpdigest.com/2021/09/27/rf-signal-chain-discourse-part-2-essential-building-blocks/" /><meta property="description" content="
by Anton Patyuchenko, Field Applications Engineer, Analog "/><title>RF Signal Chain Discourse — Part 2: Essential Building Blocks &#8211; Microwave Product Digest</title><link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin/><link rel="preconnect" href="https://fonts.googleapis.com"/><style type="text/css">@font-face {
 font-family: 'Archivo Narrow';
 font-style: normal;
 font-weight: 400;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/archivonarrow/v12/tss0ApVBdCYD5Q7hcxTE1ArZ0bbwiXk.ttf) format('truetype');
}
@font-face {
 font-family: 'Open Sans';
 font-style: italic;
 font-weight: 400;
 font-stretch: normal;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/opensans/v26/memQYaGs126MiZpBA-UFUIcVXSCEkx2cmqvXlWq8tWZ0Pw86hd0Rk8ZkWVAexQ.ttf) format('truetype');
}
@font-face {
 font-family: 'Open Sans';
 font-style: italic;
 font-weight: 800;
 font-stretch: normal;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/opensans/v26/memQYaGs126MiZpBA-UFUIcVXSCEkx2cmqvXlWq8tWZ0Pw86hd0Rk0ZjWVAexQ.ttf) format('truetype');
}
@font-face {
 font-family: 'Open Sans';
 font-style: normal;
 font-weight: 400;
 font-stretch: normal;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/opensans/v26/memSYaGs126MiZpBA-UvWbX2vVnXBbObj2OVZyOOSr4dVJWUgsjZ0B4gaVc.ttf) format('truetype');
}
@font-face {
 font-family: 'Open Sans';
 font-style: normal;
 font-weight: 800;
 font-stretch: normal;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/opensans/v26/memSYaGs126MiZpBA-UvWbX2vVnXBbObj2OVZyOOSr4dVJWUgshZ1x4gaVc.ttf) format('truetype');
}
@font-face {
 font-family: 'Oswald';
 font-style: normal;
 font-weight: 400;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/oswald/v40/TK3_WkUHHAIjg75cFRf3bXL8LICs1_FvsUZiYA.ttf) format('truetype');
}
@font-face {
 font-family: 'Roboto';
 font-style: normal;
 font-weight: 400;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/roboto/v29/KFOmCnqEu92Fr1Mu4mxP.ttf) format('truetype');
} </style><link rel="stylesheet" id="siteground-optimizer-combined-css-7e601634ebab9fcf69900a183dfa3364" href="https://www.mpdigest.com/wp-content/uploads/siteground-optimizer-assets/siteground-optimizer-combined-css-7e601634ebab9fcf69900a183dfa3364.css" media="all" /><meta name='robots' content='max-image-preview:large' /><link rel='dns-prefetch' href='//player.vimeo.com' /><link rel='dns-prefetch' href='//www.google.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel="alternate" type="application/rss+xml" title="Microwave Product Digest &raquo; Feed" href="https://www.mpdigest.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Microwave Product Digest &raquo; Comments Feed" href="https://www.mpdigest.com/comments/feed/" /><link rel="alternate" type="text/calendar" title="Microwave Product Digest &raquo; iCal Feed" href="https://www.mpdigest.com/events/?ical=1" /><link rel="alternate" type="application/rss+xml" title="Microwave Product Digest &raquo; RF Signal Chain Discourse — Part 2: Essential Building Blocks Comments Feed" href="https://www.mpdigest.com/2021/09/27/rf-signal-chain-discourse-part-2-essential-building-blocks/feed/" /> <!-- This site uses the Google Analytics by ExactMetrics plugin v7.0.2 - Using Analytics tracking - https://www.exactmetrics.com/ --> <script src="//www.googletagmanager.com/gtag/js?id=UA-72456674-1"  type="text/javascript" data-cfasync="false" async></script> <script type="text/javascript" data-cfasync="false"> var em_version = '7.0.2';
 var em_track_user = true;
 var em_no_track_reason = ''; 
 var disableStrs = [
 'ga-disable-UA-72456674-1',
 ];  /* Function to detect opted out users */
 function __gtagTrackerIsOptedOut() {
 for ( var index = 0; index < disableStrs.length; index++ ) {
 if ( document.cookie.indexOf( disableStrs[ index ] + '=true' ) > -1 ) {
 return true;
 }
 }  return false;
 }  /* Disable tracking if the opt-out cookie exists. */
 if ( __gtagTrackerIsOptedOut() ) {
 for ( var index = 0; index < disableStrs.length; index++ ) {
 window[ disableStrs[ index ] ] = true;
 }
 }  /* Opt-out function */
 function __gtagTrackerOptout() {
 for ( var index = 0; index < disableStrs.length; index++ ) {
 document.cookie = disableStrs[ index ] + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
 window[ disableStrs[ index ] ] = true;
 }
 }  if ( 'undefined' === typeof gaOptout ) {
 function gaOptout() {
 __gtagTrackerOptout();
 }
 }
 window.dataLayer = window.dataLayer || [];  window.ExactMetricsDualTracker = {
 helpers: {},
 trackers: {},
 };
 if ( em_track_user ) {
 function __gtagDataLayer() {
 dataLayer.push( arguments );
 }  function __gtagTracker( type, name, parameters ) {
 if ( type === 'event' ) { 
 parameters.send_to = exactmetrics_frontend.ua;
 __gtagDataLayer.apply( null, arguments );
 } else {
 __gtagDataLayer.apply( null, arguments );
 }
 }
 __gtagTracker( 'js', new Date() );
 __gtagTracker( 'set', {
 'developer_id.dNDMyYj' : true,
 } );
 __gtagTracker( 'config', 'UA-72456674-1', {"forceSSL":"true"} );
 window.gtag = __gtagTracker;										(
 function () {
 /* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
 /* ga and __gaTracker compatibility shim. */
 var noopfn = function () {
 return null;
 };
 var newtracker = function () {
 return new Tracker();
 };
 var Tracker = function () {
 return null;
 };
 var p = Tracker.prototype;
 p.get = noopfn;
 p.set = noopfn;
 p.send = function (){
 var args = Array.prototype.slice.call(arguments);
 args.unshift( 'send' );
 __gaTracker.apply(null, args);
 };
 var __gaTracker = function () {
 var len = arguments.length;
 if ( len === 0 ) {
 return;
 }
 var f = arguments[len - 1];
 if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
 if ( 'send' === arguments[0] ) {
 var hitConverted, hitObject = false, action;
 if ( 'event' === arguments[1] ) {
 if ( 'undefined' !== typeof arguments[3] ) {
 hitObject = {
 'eventAction': arguments[3],
 'eventCategory': arguments[2],
 'eventLabel': arguments[4],
 'value': arguments[5] ? arguments[5] : 1,
 }
 }
 }
 if ( 'pageview' === arguments[1] ) {
 if ( 'undefined' !== typeof arguments[2] ) {
 hitObject = {
 'eventAction': 'page_view',
 'page_path' : arguments[2],
 }
 }
 }
 if ( typeof arguments[2] === 'object' ) {
 hitObject = arguments[2];
 }
 if ( typeof arguments[5] === 'object' ) {
 Object.assign( hitObject, arguments[5] );
 }
 if ( 'undefined' !== typeof arguments[1].hitType ) {
 hitObject = arguments[1];
 if ( 'pageview' === hitObject.hitType ) {
 hitObject.eventAction = 'page_view';
 }
 }
 if ( hitObject ) {
 action = 'timing' === arguments[1].hitType ? 'timing_complete' : hitObject.eventAction;
 hitConverted = mapArgs( hitObject );
 __gtagTracker( 'event', action, hitConverted );
 }
 }
 return;
 }  function mapArgs( args ) {
 var arg, hit = {};
 var gaMap = {
 'eventCategory': 'event_category',
 'eventAction': 'event_action',
 'eventLabel': 'event_label',
 'eventValue': 'event_value',
 'nonInteraction': 'non_interaction',
 'timingCategory': 'event_category',
 'timingVar': 'name',
 'timingValue': 'value',
 'timingLabel': 'event_label',
 'page' : 'page_path',
 'location' : 'page_location',
 'title' : 'page_title',
 };
 for ( arg in args ) {
 if ( ! ( ! args.hasOwnProperty(arg) || ! gaMap.hasOwnProperty(arg) ) ) {
 hit[gaMap[arg]] = args[arg];
 } else {
 hit[arg] = args[arg];
 }
 }
 return hit;
 }  try {
 f.hitCallback();
 } catch ( ex ) {
 }
 };
 __gaTracker.create = newtracker;
 __gaTracker.getByName = newtracker;
 __gaTracker.getAll = function () {
 return [];
 };
 __gaTracker.remove = noopfn;
 __gaTracker.loaded = true;
 window['__gaTracker'] = __gaTracker;
 }
 )();
 } else {
 console.log( "" );
 ( function () {
 function __gtagTracker() {
 return null;
 }
 window['__gtagTracker'] = __gtagTracker;
 window['gtag'] = __gtagTracker;
 } )();
 }
 </script> <!-- / Google Analytics by ExactMetrics --> <script type='text/javascript' src='https://www.mpdigest.com/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script> <script type='text/javascript' src='https://www.mpdigest.com/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script> <script type='text/javascript' id='wti_like_post_script-js-extra'> /* <![CDATA[ */
var wtilp = {"ajax_url":"https:\/\/www.mpdigest.com\/wp-admin\/admin-ajax.php"};
/* ]]> */ </script> <script type='text/javascript' src='https://www.mpdigest.com/wp-content/uploads/siteground-optimizer-assets/wti_like_post_script.min.js' id='wti_like_post_script-js'></script> <script type='text/javascript' id='exactmetrics-frontend-script-js-extra'> /* <![CDATA[ */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/www.mpdigest.com","hash_tracking":"false","ua":"UA-72456674-1","v4_id":""};
/* ]]> */ </script> <script type='text/javascript' src='https://www.mpdigest.com/wp-content/plugins/google-analytics-dashboard-for-wp/assets/js/frontend-gtag.min.js' id='exactmetrics-frontend-script-js'></script> <script type='text/javascript' id='ajax-request-js-extra'> /* <![CDATA[ */
var cactus = {"ajaxurl":"https:\/\/www.mpdigest.com\/wp-admin\/admin-ajax.php","query_vars":{"page":0,"year":2021,"monthnum":9,"day":27,"name":"rf-signal-chain-discourse-part-2-essential-building-blocks","error":"","m":"","p":0,"post_parent":"","subpost":"","subpost_id":"","attachment":"","attachment_id":0,"pagename":"","page_id":0,"second":"","minute":"","hour":"","w":0,"category_name":"","tag":"","cat":"","tag_id":"","author":"","author_name":"","feed":"","tb":"","paged":0,"meta_key":"","meta_value":"","preview":"","s":"","sentence":"","title":"","fields":"","menu_order":"","embed":"","category__in":[],"category__not_in":[],"category__and":[],"post__in":[],"post__not_in":[],"post_name__in":[],"tag__in":[],"tag__not_in":[],"tag__and":[],"tag_slug__in":[],"tag_slug__and":[],"post_parent__in":[],"post_parent__not_in":[],"author__in":[],"author__not_in":[],"ignore_sticky_posts":false,"suppress_filters":false,"cache_results":true,"update_post_term_cache":true,"lazy_load_term_meta":true,"update_post_meta_cache":true,"post_type":"","posts_per_page":10,"nopaging":false,"comments_per_page":"50","no_found_rows":false,"order":"DESC"},"current_url":"https:\/\/www.mpdigest.com\/2021\/09\/27\/rf-signal-chain-discourse-part-2-essential-building-blocks"};
/* ]]> */ </script> <script type='text/javascript' src='https://www.mpdigest.com/wp-content/uploads/siteground-optimizer-assets/ajax-request.min.js' id='ajax-request-js'></script><link rel="https://api.w.org/" href="https://www.mpdigest.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.mpdigest.com/wp-json/wp/v2/posts/20993" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.mpdigest.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.mpdigest.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.8.1" /><meta name="generator" content="Seriously Simple Podcasting 2.9.1" /><link rel="canonical" href="https://www.mpdigest.com/2021/09/27/rf-signal-chain-discourse-part-2-essential-building-blocks/" /><link rel='shortlink' href='https://www.mpdigest.com/?p=20993' /><link rel="alternate" type="application/json+oembed" href="https://www.mpdigest.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mpdigest.com%2F2021%2F09%2F27%2Frf-signal-chain-discourse-part-2-essential-building-blocks%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.mpdigest.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mpdigest.com%2F2021%2F09%2F27%2Frf-signal-chain-discourse-part-2-essential-building-blocks%2F&#038;format=xml" /> <!-- This site is using AdRotate v5.8.21 to display their advertisements - https://ajdg.solutions/ --> <!-- AdRotate CSS --> <style type="text/css" media="screen"> .g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
 .g img { height:auto; }
 .g-col { position:relative; float:left; }
 .g-col:first-child { margin-left: 0; }
 .g-col:last-child { margin-right: 0; }
 .g-1 { width:100%; max-width:160px; height:100%; max-height:600px; margin: 0 auto; }
 .g-2 { width:100%; max-width:490px; height:100%; max-height:90px; margin: 0 auto; }
 .g-3 { width:100%; max-width:250px; height:100%; max-height:250px; margin: 0 auto; }
 @media only screen and (max-width: 480px) {
 .g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
 } </style> <!-- /AdRotate CSS --><link rel="alternate" type="application/rss+xml" title="Podcast RSS feed" href="http://feeds.soundcloud.com/users/soundcloud:users:650029794/sounds.rss" /><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://www.mpdigest.com"><link rel="https://theeventscalendar.com/" href="https://www.mpdigest.com/wp-json/tribe/events/v1/" /><meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/><link rel="icon" href="https://www.mpdigest.com/wp-content/uploads/2016/01/cropped-MPD-WebIcon-2019-32x32.gif" sizes="32x32" /><link rel="icon" href="https://www.mpdigest.com/wp-content/uploads/2016/01/cropped-MPD-WebIcon-2019-192x192.gif" sizes="192x192" /><link rel="apple-touch-icon" href="https://www.mpdigest.com/wp-content/uploads/2016/01/cropped-MPD-WebIcon-2019-180x180.gif" /><meta name="msapplication-TileImage" content="https://www.mpdigest.com/wp-content/uploads/2016/01/cropped-MPD-WebIcon-2019-270x270.gif" /> <!-- custom css --> <style type="text/css">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</style> <!-- end custom css --><noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head><body class="post-template-default single single-post postid-20993 single-format-standard tribe-no-js group-blog wpb-js-composer js-comp-ver-6.7.0 vc_responsive"> <style type="text/css" rel="stylesheet" scoped>#body-wrap{background:#b7b7b7 ;}</style><div id="body-wrap" class=""><div id="wrap"><header class=""> <!--Navigation style--><div class="cactus-nav style-2"> <!--Top NAV--><div id="top-nav"><nav class="navbar navbar-default" role="navigation"><div class="container"> <!--Headlines--><aside id="headline_id-2" class="widget col-md-12 nav navbar-nav navbar-left cactus-headline rps-hidden module widget-col headline"><div class="widget-inner"><ul class="nav navbar-nav navbar-left rps-hidden"><li class="title">Headlines</li><li class="navigation"><div class="button-prev"><i class="fa fa-angle-left"></i></div><div class="button-next"><i class="fa fa-angle-right"></i></div></li><li class="cactus-swiper-container" data-settings="[mode:cactus-fix-composer]"><div class="swiper-wrapper"><div class="swiper-slide"><div class="cactus-note-cat"><a href="https://www.mpdigest.com/category/blog/" title="View all posts in Blog">Blog</a></div><a class="title-slide" href="https://www.mpdigest.com/2021/09/27/monitoring-the-charging-stations-of-the-e-bus-fleet-of-the-city-of-jena/" title="Monitoring the Charging Stations of the E-bus Fleet of the City of Jena">Monitoring the Charging Stations of the E-bus Fleet of the City of Jena</a></div><div class="swiper-slide"><div class="cactus-note-cat"><a href="https://www.mpdigest.com/category/featured-articles/" title="View all posts in Featured Articles">Featured Articles</a></div><a class="title-slide" href="https://www.mpdigest.com/2021/09/27/rf-signal-chain-discourse-part-2-essential-building-blocks/" title="RF Signal Chain Discourse — Part 2: Essential Building Blocks">RF Signal Chain Discourse — Part 2: Essential Building Blocks</a></div><div class="swiper-slide"><div class="cactus-note-cat"><a href="https://www.mpdigest.com/category/blog/" title="View all posts in Blog">Blog</a></div><a class="title-slide" href="https://www.mpdigest.com/2021/09/27/what-lies-beneath/" title="What Lies Beneath">What Lies Beneath</a></div><div class="swiper-slide"><div class="cactus-note-cat"><a href="https://www.mpdigest.com/category/in-the-news/" title="View all posts in In The News">In The News</a></div><a class="title-slide" href="https://www.mpdigest.com/2021/09/24/infinite-electronics-inc-names-matthias-norweg-for-the-role-of-senior-vice-president-of-corporate-development/" title="Infinite Electronics, Inc. Names Matthias Norweg for the Role of Senior Vice President of Corporate Development">Infinite Electronics, Inc. Names Matthias Norweg for the Role of Senior Vice President of Corporate Development</a></div><div class="swiper-slide"><div class="cactus-note-cat"><a href="https://www.mpdigest.com/category/featured-articles/" title="View all posts in Featured Articles">Featured Articles</a></div><a class="title-slide" href="https://www.mpdigest.com/2021/09/24/the-perils-of-pim-remain-a-problem-for-antennas-too/" title="The Perils of PIM Remain a Problem&#8230; for Antennas, Too">The Perils of PIM Remain a Problem&#8230; for Antennas, Too</a></div><div class="swiper-slide"><div class="cactus-note-cat"><a href="https://www.mpdigest.com/category/on-the-market/" title="View all posts in On The Market">On The Market</a></div><a class="title-slide" href="https://www.mpdigest.com/2021/09/23/new-oscilloscope-series/" title="New Oscilloscope Series">New Oscilloscope Series</a></div><div class="swiper-slide"><div class="cactus-note-cat"><a href="https://www.mpdigest.com/category/on-the-market/" title="View all posts in On The Market">On The Market</a></div><a class="title-slide" href="https://www.mpdigest.com/2021/09/23/victs-antennas-for-space-payloads/" title="VICTS Antennas for Space Payloads">VICTS Antennas for Space Payloads</a></div><div class="swiper-slide"><div class="cactus-note-cat"><a href="https://www.mpdigest.com/category/on-the-market/" title="View all posts in On The Market">On The Market</a></div><a class="title-slide" href="https://www.mpdigest.com/2021/09/23/industrial-grade-ssds/" title="Industrial-Grade SSDs">Industrial-Grade SSDs</a></div></div></li></ul></div></aside> <!--Headlines--><ul class="nav navbar-nav navbar-right top-menu-rps cactus-login"><li> <a href="https://www.mpdigest.com/wp-login.php?redirect_to=https%3A%2F%2Fwww.mpdigest.com%3A443%2F2021%2F09%2F27%2Frf-signal-chain-discourse-part-2-essential-building-blocks%2F">login</a></li></ul> <!--Share list--><ul class='nav navbar-nav navbar-right social-listing list-inline social-accounts'><li class="facebook"><a target='_blank' href="https://www.facebook.com/microwaveproductdigest/" title='Facebook'><i class="fa fa-facebook"></i></a></li><li class="youtube"><a target='_blank' href="https://www.youtube.com/channel/UCdabatwIzP2Mtb0ZREHxQsA" title='YouTube'><i class="fa fa-youtube"></i></a></li><li class="twitter"><a target='_blank' href="https://twitter.com/MPD_socialmedia" title='Twitter'><i class="fa fa-twitter"></i></a></li><li class="linkedin"><a target='_blank' href="https://www.linkedin.com/company/microwave-product-digest" title='LinkedIn'><i class="fa fa-linkedin"></i></a></li><li class="envelope"><a  href="mailto:socialmedia@mpdigest.com" title='Email'><i class="fa fa-envelope"></i></a></li></ul> <!--Share list--> <!--Menu--><ul class="nav navbar-nav navbar-right rps-hidden top-menu-rps"></ul><!--Menu--> <!--mobile--> <!--mobile--></div></nav></div> <!--Top NAV--> <!--Branding--><div id="main-nav" class="nav-branding"><nav class="navbar navbar-default" role="navigation"><div class="container"> <!--Logo--><div class="navbar-header"> <!--logo--> <a class="navbar-brand" href="https://www.mpdigest.com"><div class="primary-logo"> <img src="https://www.mpdigest.com/wp-content/uploads/2016/01/MPD-Logo-NonRetina-2019.png" alt="Microwave Product Digest" title="Microwave Product Digest"></div> </a><!--logo--></div><!--Logo--><ul class="nav navbar-nav navbar-right rps-hidden cactus-header-ads"><li><div class='ad ads_top_nav'><a href="https://lp.minicircuits.com/en-us/ism-rf-energy-solutions?utm_campaign=08-21-bannerad&utm_source=mpd&utm_medium=banner&utm_content=rf-energy-leaderboard" onclick="trackOutboundLink('https://lp.minicircuits.com/en-us/ism-rf-energy-solutions?utm_campaign=08-21-bannerad&utm_source=mpd&utm_medium=banner&utm_content=rf-energy-leaderboard'); return false;" target="_blank"><img src="https://www.mpdigest.com/wp-content/uploads/2021/08/Leaderboard_MWPD_July2021.jpeg" alt="" /></a></div></li></ul></div></nav></div> <!--Branding--> <!--Primary menu--><div id="main-menu"><nav class="navbar navbar-default " role="navigation"><div class="container"><div class="main-menu-wrap"><ul class="nav navbar-nav cactus-logo-nav is-sticky-menu"><li><a href="https://www.mpdigest.com"><img src="https://www.mpdigest.com/wp-content/uploads/2016/01/MPD-Logo-Sticky-2019.png" alt="Microwave Product Digest" title="Microwave Product Digest"></a></li></ul><ul class="nav navbar-nav open-menu-mobile"><li class="show-mobile open-menu-mobile-rps"><a href="javascript:;"><i class="fa fa-bars"></i></a></li></ul> <!--HTML Struc (truemag)--><ul class="nav navbar-nav cactus-main-menu "><li id="nav-menu-item-136" class="main-menu-item menu-item-depth-0 menu-item menu-item-type-post_type menu-item-object-page menu-item-home"><a href="https://www.mpdigest.com/" class="menu-link  main-menu-link">Home </a></li><li id="nav-menu-item-134" class="main-menu-item menu-item-depth-0 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.mpdigest.com/issues-supplements/" class="menu-link  main-menu-link">Issues &#038; Supplements </a></li><li id="nav-menu-item-13935" class="main-menu-item menu-item-depth-0 menu-item menu-item-type-custom menu-item-object-custom"><a href="https://www.mpdigest.com/podcast" class="menu-link  main-menu-link">MPD Podcasts </a></li><li id="nav-menu-item-135" class="main-menu-item menu-item-depth-0 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.mpdigest.com/military-products/" class="menu-link  main-menu-link">Military Products </a></li><li id="nav-menu-item-173" class="main-menu-item menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-tribe_events_cat"><a href="https://www.mpdigest.com/events/category/events/" class="menu-link  main-menu-link">Events </a></li><li id="nav-menu-item-151" class="main-menu-item menu-item-depth-0 menu-item menu-item-type-custom menu-item-object-custom"><a target="_blank" href="http://www.b2bmediaportal.com/register.aspx?fid=MPDCS" class="menu-link  main-menu-link">Subscribe </a></li><li id="nav-menu-item-180" class="main-menu-item menu-item-depth-0 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children parent dropdown"><a href="#" class="menu-link dropdown-toggle disabled main-menu-link" data-toggle="dropdown">Contact Us </a><ul class="dropdown-menu menu-depth-1"><li id="nav-menu-item-175" class="sub-menu-item menu-item-depth-1 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.mpdigest.com/contact-us/" class="menu-link  sub-menu-link">Contact Us </a></li><li id="nav-menu-item-179" class="sub-menu-item menu-item-depth-1 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.mpdigest.com/contact-us/about-us/" class="menu-link  sub-menu-link">About Us </a></li><li id="nav-menu-item-166" class="sub-menu-item menu-item-depth-1 menu-item menu-item-type-custom menu-item-object-custom"><a target="_blank" href="https://www.mpdigest.com/wp-content/uploads/2021/02/Media_Kit_2_3_2021_MJ.pdf" class="menu-link  sub-menu-link">Download Media Guide </a></li></ul></li><li id="nav-menu-item-165" class="main-menu-item menu-item-depth-0 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children parent dropdown"><a href="#" class="menu-link dropdown-toggle disabled main-menu-link" data-toggle="dropdown">Editorial </a><ul class="dropdown-menu menu-depth-1"><li id="nav-menu-item-162" class="sub-menu-item menu-item-depth-1 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.mpdigest.com/editorial-calendar/" class="menu-link  sub-menu-link">Editorial Calendar </a></li><li id="nav-menu-item-153" class="sub-menu-item menu-item-depth-1 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.mpdigest.com/article-submission-requirements/" class="menu-link  sub-menu-link">Article Submission Requirements </a></li><li id="nav-menu-item-156" class="sub-menu-item menu-item-depth-1 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.mpdigest.com/product-submission-requirements/" class="menu-link  sub-menu-link">Product Submission Requirements </a></li></ul></li></ul> <!--HTML Struc (truemag)--> <!--Search--><ul class="nav navbar-nav navbar-right search-drop-down dark-div"><li> <a href="javascript:;" class="open-search-main-menu"><i class="fa fa-search"></i><i class="fa fa-times"></i></a><ul class="search-main-menu"><li><form action="https://www.mpdigest.com" method="get"> <input type="hidden" name="post_type" value="post"> <input type="text" placeholder="Search..." name="s" value=""> <i class="fa fa-search"></i> <input type="submit" value="search"></form></li></ul></li></ul> <!--Search--></div></div></nav> <input type="hidden" name="sticky_navigation" value="on"/></div> <!--Primary menu--></div> <!--Navigation style--></header><div id="cactus-body-container"> <!--Add class cactus-body-container for single page--><div class="cactus-single-page cactus-sidebar-control sb-right  "><div class="container"><div class="row"><div class="main-content-col col-md-12 cactus-config-single"> <!--breadcrumb--><ol class="cactus-breadcrumb" itemscope itemtype="http://schema.org/BreadcrumbList"><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a itemprop="item" href="https://www.mpdigest.com/"><span itemprop="name">Home</span></a><meta itemprop="position" content="1" /></li> <i class="fa fa-angle-right"></i><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a itemprop="item" href=""><span itemprop="name">Featured</span></a><meta itemprop="position" content="2" /></li> <i class="fa fa-angle-right"></i><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a itemprop="item" href=""><span itemprop="name">Articles</span></a><meta itemprop="position" content="3" /></li> <i class="fa fa-angle-right"></i><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="current"><span itemprop="name">RF Signal Chain Discourse — Part 2: Essential Building Blocks</span><meta itemprop="position" content="4" /></li></ol><!-- .breadcrumbs --> <!--breadcrumb--><div id='single-post' class="single-post-content"><article data-id="20993" data-url='https://www.mpdigest.com/2021/09/27/rf-signal-chain-discourse-part-2-essential-building-blocks/' data-timestamp='1632754800' data-count='0' data-enable-fb-comment='0' id="post-20993" class="cactus-single-content post-20993 post type-post status-publish format-standard hentry category-featured-articles tag-analog-devices-inc" ><div class="heading-post"> <!--info--><div class="posted-on"><div class="cactus-note-cat"><a href="https://www.mpdigest.com/category/featured-articles/" title="View all posts in Featured Articles">Featured Articles</a></div><div class="fix-responsive"></div> <a href="https://www.mpdigest.com/2021/09/27/rf-signal-chain-discourse-part-2-essential-building-blocks/" class="cactus-info" rel="bookmark"><time datetime="2021-09-27T15:00:00-04:00" class="entry-date updated">September 27, 2021</time></a> <span class="vcard author"> <span class="fn"><a href="https://www.mpdigest.com/author/admin/" title="Posts by mpdigest" rel="author">mpdigest</a></span> </span> <a href="https://www.mpdigest.com/2021/09/27/rf-signal-chain-discourse-part-2-essential-building-blocks/#respond" class="comment cactus-info">0</a></div><!--info--> <!--Title--><h1 class="h3 title entry-title"> RF Signal Chain Discourse — Part 2: Essential Building Blocks</h1> <!--Title--></div><div class="update_design_post_on"><div class="posted-on"><div class="view cactus-info">20</div> <a href="https://www.mpdigest.com/2021/09/27/rf-signal-chain-discourse-part-2-essential-building-blocks/#respond" class="comment cactus-info">0</a></div></div><div class="cactus-share-and-like fix-left"> <a class="share-tool-block open-cactus-share" data-toggle="tooltip" data-placement="top" href="javascript:;" title="" data-original-title="social share"> <i class="fa fa-share-alt"></i> <i class="fa fa-times"></i> <span>Share</span> </a><ul class="social-listing list-inline change-color"><li class="facebook"> <a class="trasition-all" title="Share on Facebook" href="#" target="_blank" rel="nofollow" onclick="window.open('https://www.facebook.com/sharer/sharer.php?u='+'https%3A%2F%2Fwww.mpdigest.com%2F2021%2F09%2F27%2Frf-signal-chain-discourse-part-2-essential-building-blocks%2F','facebook-share-dialog','width=626,height=436');return false;"><i class="fa fa-facebook"></i> </a></li><li class="twitter"> <a class="trasition-all" href="#" title="Share on Twitter" rel="nofollow" target="_blank" onclick="window.open('http://twitter.com/share?text=RF+Signal+Chain+Discourse+%E2%80%94+Part+2%3A+Essential+Building+Blocks&amp;url=https%3A%2F%2Fwww.mpdigest.com%2F2021%2F09%2F27%2Frf-signal-chain-discourse-part-2-essential-building-blocks%2F','twitter-share-dialog','width=626,height=436');return false;"><i class="fa fa-twitter"></i> </a></li><li class="linkedin"> <a class="trasition-all" href="#" title="Share on LinkedIn" rel="nofollow" target="_blank" onclick="window.open('http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fwww.mpdigest.com%2F2021%2F09%2F27%2Frf-signal-chain-discourse-part-2-essential-building-blocks%2F&amp;title=RF+Signal+Chain+Discourse+%E2%80%94+Part+2%3A+Essential+Building+Blocks&amp;source=Microwave+Product+Digest','linkedin-share-dialog','width=626,height=436');return false;"><i class="fa fa-linkedin"></i> </a></li><li class="tumblr"> <a class="trasition-all" href="#" title="Share on Tumblr" rel="nofollow" target="_blank" onclick="window.open('http://www.tumblr.com/share/link?url=https%3A%2F%2Fwww.mpdigest.com%2F2021%2F09%2F27%2Frf-signal-chain-discourse-part-2-essential-building-blocks%2F&amp;name=RF+Signal+Chain+Discourse+%E2%80%94+Part+2%3A+Essential+Building+Blocks','tumblr-share-dialog','width=626,height=436');return false;"><i class="fa fa-tumblr"></i> </a></li><li class="google-plus"> <a class="trasition-all" href="#" title="Share on Google Plus" rel="nofollow" target="_blank" onclick="window.open('https://plus.google.com/share?url=https%3A%2F%2Fwww.mpdigest.com%2F2021%2F09%2F27%2Frf-signal-chain-discourse-part-2-essential-building-blocks%2F','googleplus-share-dialog','width=626,height=436');return false;"><i class="fa fa-google-plus"></i> </a></li><li class="pinterest"> <a class="trasition-all" href="#" title="Pin this" rel="nofollow" target="_blank" onclick="window.open('//pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.mpdigest.com%2F2021%2F09%2F27%2Frf-signal-chain-discourse-part-2-essential-building-blocks%2F&amp;media=&amp;description=RF+Signal+Chain+Discourse+%E2%80%94+Part+2%3A+Essential+Building+Blocks','pin-share-dialog','width=626,height=436');return false;"><i class="fa fa-pinterest"></i> </a></li><li class="vk"> <a class="trasition-all" href="#" title="Share on VK" rel="nofollow" target="_blank" onclick="window.open('//vkontakte.ru/share.php?url=https%3A%2F%2Fwww.mpdigest.com%2F2021%2F09%2F27%2Frf-signal-chain-discourse-part-2-essential-building-blocks%2F','vk-share-dialog','width=626,height=436');return false;"><i class="fa fa-vk"></i> </a></li><li class="email"> <a class="trasition-all" href="mailto:?subject=RF+Signal+Chain+Discourse+%E2%80%94+Part+2%3A+Essential+Building+Blocks&amp;body=https%3A%2F%2Fwww.mpdigest.com%2F2021%2F09%2F27%2Frf-signal-chain-discourse-part-2-essential-building-blocks%2F" title="Email this"><i class="fa fa-envelope"></i> </a></li></ul><div class="share-tool-block view-count"> <i class="fa fa-eye"></i>&nbsp; <span>20</span></div><div class="share-tool-block like-button fix-left_check-like-id-20993" data-like="like" data-unlike="dislike"><div class='watch-action'><div class='watch-position align-left'><div class='action-like'><a class='lbg-style1 like-20993 jlk' href='javascript:void(0)' data-task='like' data-post_id='20993' data-nonce='58df75421f' rel='nofollow'><img class='wti-pixel' src='https://www.mpdigest.com/wp-content/plugins/wti-like-post/images/pixel.gif' title='Like' /><span class='lc-20993 lc'>0</span></a></div><div class='action-unlike'><a class='unlbg-style1 unlike-20993 jlk' href='javascript:void(0)' data-task='unlike' data-post_id='20993' data-nonce='58df75421f' rel='nofollow'><img class='wti-pixel' src='https://www.mpdigest.com/wp-content/plugins/wti-like-post/images/pixel.gif' title='Unlike' /><span class='unlc-20993 unlc'>0</span></a></div></div><div class='status-20993 status align-left'></div></div><div class='wti-clear'></div></div><div class="share-tool-block like-information"><div class="cactus-like-bar"><span style="width:50%;"></span></div><div class="like-dislike pull-right"> <span class="like"><i class="fa fa-thumbs-up"></i>&nbsp; 0</span> <span class="dislike"><i class="fa fa-thumbs-down"></i>&nbsp; 0</span></div></div> <script> /*like*/
 var __like_number_20993 = document.createElement('SPAN');
 __like_number_20993.className = 'lc';
 var __like_numbertext_20993 = document.createTextNode('0');
 __like_number_20993.appendChild(__like_numbertext_20993);
 var __likediv_20993 = document.querySelector('.fix-left_check-like-id-20993 .lbg-style1');
 __likediv_20993.appendChild(__like_number_20993);  /*unlike*/
 var __unlike_number_20993 = document.createElement('SPAN');
 __unlike_number_20993.className = 'unlc';
 var __unlike_numbertext_20993 = document.createTextNode('0');
 __unlike_number_20993.appendChild(__unlike_numbertext_20993);
 var __unlikediv_20993 = document.querySelector('.fix-left_check-like-id-20993 .unlbg-style1');
 __unlikediv_20993.appendChild(__unlike_number_20993); </script><div class="clearfix"></div> <!--Share--><ul class="social-listing list-inline mobile-open change-color"><li class="facebook"> <a class="trasition-all" title="Share on Facebook" href="#" target="_blank" rel="nofollow" onclick="window.open('https://www.facebook.com/sharer/sharer.php?u='+'https%3A%2F%2Fwww.mpdigest.com%2F2021%2F09%2F27%2Frf-signal-chain-discourse-part-2-essential-building-blocks%2F','facebook-share-dialog','width=626,height=436');return false;"><i class="fa fa-facebook"></i> </a></li><li class="twitter"> <a class="trasition-all" href="#" title="Share on Twitter" rel="nofollow" target="_blank" onclick="window.open('http://twitter.com/share?text=RF+Signal+Chain+Discourse+%E2%80%94+Part+2%3A+Essential+Building+Blocks&amp;url=https%3A%2F%2Fwww.mpdigest.com%2F2021%2F09%2F27%2Frf-signal-chain-discourse-part-2-essential-building-blocks%2F','twitter-share-dialog','width=626,height=436');return false;"><i class="fa fa-twitter"></i> </a></li><li class="linkedin"> <a class="trasition-all" href="#" title="Share on LinkedIn" rel="nofollow" target="_blank" onclick="window.open('http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fwww.mpdigest.com%2F2021%2F09%2F27%2Frf-signal-chain-discourse-part-2-essential-building-blocks%2F&amp;title=RF+Signal+Chain+Discourse+%E2%80%94+Part+2%3A+Essential+Building+Blocks&amp;source=Microwave+Product+Digest','linkedin-share-dialog','width=626,height=436');return false;"><i class="fa fa-linkedin"></i> </a></li><li class="tumblr"> <a class="trasition-all" href="#" title="Share on Tumblr" rel="nofollow" target="_blank" onclick="window.open('http://www.tumblr.com/share/link?url=https%3A%2F%2Fwww.mpdigest.com%2F2021%2F09%2F27%2Frf-signal-chain-discourse-part-2-essential-building-blocks%2F&amp;name=RF+Signal+Chain+Discourse+%E2%80%94+Part+2%3A+Essential+Building+Blocks','tumblr-share-dialog','width=626,height=436');return false;"><i class="fa fa-tumblr"></i> </a></li><li class="google-plus"> <a class="trasition-all" href="#" title="Share on Google Plus" rel="nofollow" target="_blank" onclick="window.open('https://plus.google.com/share?url=https%3A%2F%2Fwww.mpdigest.com%2F2021%2F09%2F27%2Frf-signal-chain-discourse-part-2-essential-building-blocks%2F','googleplus-share-dialog','width=626,height=436');return false;"><i class="fa fa-google-plus"></i> </a></li><li class="pinterest"> <a class="trasition-all" href="#" title="Pin this" rel="nofollow" target="_blank" onclick="window.open('//pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.mpdigest.com%2F2021%2F09%2F27%2Frf-signal-chain-discourse-part-2-essential-building-blocks%2F&amp;media=&amp;description=RF+Signal+Chain+Discourse+%E2%80%94+Part+2%3A+Essential+Building+Blocks','pin-share-dialog','width=626,height=436');return false;"><i class="fa fa-pinterest"></i> </a></li><li class="vk"> <a class="trasition-all" href="#" title="Share on VK" rel="nofollow" target="_blank" onclick="window.open('//vkontakte.ru/share.php?url=https%3A%2F%2Fwww.mpdigest.com%2F2021%2F09%2F27%2Frf-signal-chain-discourse-part-2-essential-building-blocks%2F','vk-share-dialog','width=626,height=436');return false;"><i class="fa fa-vk"></i> </a></li><li class="email"> <a class="trasition-all" href="mailto:?subject=RF+Signal+Chain+Discourse+%E2%80%94+Part+2%3A+Essential+Building+Blocks&amp;body=https%3A%2F%2Fwww.mpdigest.com%2F2021%2F09%2F27%2Frf-signal-chain-discourse-part-2-essential-building-blocks%2F" title="Email this"><i class="fa fa-envelope"></i> </a></li></ul> <!--Share--></div><div class="body-content style-5" ><p>by Anton Patyuchenko, Field Applications Engineer, <strong><a href="http://www.analog.com" target="_blank" rel="noreferrer noopener">Analog Devices, Inc.</a></strong></p><p>Discrete and integrated components represent functional building blocks underpinning RF signal chains across all application domains. In Part 1 of our discourse (published in the June issue of <em>Microwave Product Digest</em>, <a rel="noreferrer noopener" href="https://www.mpdigest.com/2021/06/22/rf-signal-chain-discourse-properties-and-performance-metrics/" target="_blank">click here to read</a>) we considered the main properties and performance metrics used for their characterization. To achieve the desired performance, however, an RF system engineer must also have a solid understanding of a broad variety of RF components, the choice of which will determine the overall performance of the complete RF signal chain in the final application.</p><p>Part 2 (Part 1 was featured in the June 2021 issue of MPD) of our discourse will detail a concise overview of the key types of different components used in a typical RF signal chain, depicted in its generic form in <strong>Figure 1</strong>. We will limit our discussion to most common RF integrated circuits (ICs), relying on the classification criteria relevant for the signal chain definition on a system level. This assessment includes RF amplifiers, frequency generation ICs, frequency multipliers and dividers, mixers, filters, and switches, as well as attenuator and detector components, and it can serve as an RF system designer’s guide to selecting the right building blocks for the target application.</p><div class="wp-block-image"><figure class="aligncenter size-large"><img loading="lazy" width="1024" height="491" src="https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-01-1024x491.jpg" alt="" class="wp-image-20987" srcset="https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-01-1024x491.jpg 1024w, https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-01-300x144.jpg 300w, https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-01-768x368.jpg 768w, https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-01-1536x737.jpg 1536w, https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-01-2048x983.jpg 2048w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption>Figure 1: A generic RF signal chain</figcaption></figure></div><p><strong>RF Amplifiers</strong></p><p>The key function of an amplifier is to increase the level of an input signal to produce a greater signal at the output. The main attribute of any RF amplifier is its gain, which describes the ratio of the output power to the input power. However, an optimum amplifier design is always a trade-off between its gain, noise, bandwidth, efficiency, linearity, and other performance parameters. Considering these characteristics as the main classification criteria, we can distinguish between various types of amplifiers designed to offer performance optimized for specific application scenarios.</p><p>Low noise amplifiers (LNAs) are optimized to increase the level of low power signals without introducing significant noise. The noise figure (NF) of a good LNA can be less than 1 dB in the sub-GHz range and a few dB at higher frequencies. Since the overall noise figure of a signal chain is dominated by its first stages, LNAs are often used at the front end of a receiver to maximize its sensitivity. On the contrary, power amplifiers (PAs) are usually used in the output stages of a transmit signal chain. They are optimized for power handling to deliver high output power with high efficiency while maintaining low heat dissipation.</p><p>High IP3, or high linearity amplifiers, share similar characteristics with PAs as they offer a high dynamic range performance. However, this type of amplifier is optimized for linearity and preferred to PAs in applications where signals with high peak-to-average power ratios are used. For instance, in communication systems relying on vector modulated signals, high linearity amplifiers allow minimization of distortions, which is critical for achieving low bit error rates.</p><p>Variable gain amplifiers (VGAs) address high dynamic range applications, too, but with a wide range of signal levels. VGAs accommodate signal variations by gain regulation to control transmit or adjust received signal amplitude. Digitally controlled VGAs are chosen if the control parameters are available on a data bus and a stepwise gain adjustment is not critical for the application. An analog controlled VGA is the solution of choice when digital control data is not available or the application cannot tolerate the step disturbance. VGAs are often used for automatic gain control (AGC) or for compensation of gain drift due to variations in temperature or characteristics of other components.</p><p>LNAs, PAs, VGAs, and other types of RF amplifiers can also be classified as wideband amplifiers if they are designed to operate over a broad range of frequencies (up to several octaves). Such amplifiers offer wideband amplification with a moderate gain, which is often needed in front-end stages of the main signal path in broadband applications. Wideband amplifiers often rely on distributed amplifier circuit designs and offer a large gain-bandwidth product, usually at the cost of efficiency and noise.</p><p>Some RF amplifiers also belong to the general category of driver amplifiers (or just drivers). A driver is an amplifier used to control another component such as the second amplifier, mixer, converter, or other element in a signal chain. The main function of the driver amplifier is to regulate certain operational parameters to ensure optimum operational conditions for the attached component. Driver amplifiers do not necessarily have to be designed to drive a specific component, but any RF amplifier regardless of its type can be considered a driver if its use case suggests fulfillment of a driving function. Similarly, we can also recognize the general category of buffer amplifiers (or just buffers), which are used to prevent the signal source from being affected by the load. For instance, buffer amplifiers are often utilized to isolate a local oscillator from a load to minimize the undesired impact of the load impedance variations on the performance of the oscillator.</p><p>Considering a classical superheterodyne architecture, in the broad category of RF amplifiers we can also distinguish local oscillator (LO) and intermediate frequency (IF) amplifiers. The main difference between these amplifiers is their functional purpose in the signal chain. The LO amplifiers are used in the LO path to ensure the required LO drive level for a mixer (they are usually called LO drivers or LO buffers), while the IF amplifiers are designed to operate at lower frequencies, which makes them a solution of choice for the intermediate frequency stages of a signal chain.</p><p>A gain block is another general type of amplifier that can be used in RF, IF, or LO signal paths, as it provides good gain flatness and return loss. Its design often incorporates internal matching and biasing circuits, which simplify its integration into a signal chain by requiring a minimal number of external components. Gain block amplifiers can serve both general purpose as well as specific needs covering various frequencies, bandwidths, gains, and output power levels.</p><p>The broad diversity of RF amplifiers is certainly not limited to only those discussed in this article. Based on amplifier characteristics, we can recognize many other types of RF amplifiers that offer different combinations of performance characteristics—for example, limiting amplifiers deliver stable compressed output power over a wide input power range, low phase noise amplifiers are optimized for high signal integrity applications, and logarithmic amplifiers are typically in essence RF-to-DC converters fulfilling the RF detection function (see the section “RF Detectors”), just to name a few. A summary of the key amplifier types we have discussed in this discourse is given in <strong>Table 1</strong>.</p><div class="wp-block-image"><figure class="aligncenter size-full"><img loading="lazy" width="876" height="607" src="https://www.mpdigest.com/wp-content/uploads/2021/09/Table-01-1.jpg" alt="" class="wp-image-20992" srcset="https://www.mpdigest.com/wp-content/uploads/2021/09/Table-01-1.jpg 876w, https://www.mpdigest.com/wp-content/uploads/2021/09/Table-01-1-300x208.jpg 300w, https://www.mpdigest.com/wp-content/uploads/2021/09/Table-01-1-768x532.jpg 768w" sizes="(max-width: 876px) 100vw, 876px" /><figcaption>Table 1: Summary of Some Key Types of RF Amplifiers</figcaption></figure></div><p>RF amplifiers can also be classified based upon other criteria such as their features, operational modes (amplifier classes), assembly, or process technology, which extends their full classification beyond the scope of this article. However, in this section we have considered some of the most common categories of RF amplifiers adapted in the industry for the definition of RF signal chain architectures.</p><p><strong>Frequency Generation ICs</strong></p><p>Frequency generation components can serve a variety of different functions in an RF signal chain, including frequency conversion, waveform synthesis, signal modulation, and clock signal generation. Depending on the target use case of an IC, there are a few performance criteria that govern its choice, including the output frequency range, spectral purity, stability, and the tuning speed. There is a broad selection of frequency generation components optimized for various use cases, among which are voltage controlled oscillator (VCO), phase-locked loop (PLL), integrated frequency synthesizer, translation loop, and direct digital synthesis (DDS) ICs.</p><p>A voltage controlled oscillator (VCO) produces an output signal whose frequency is controlled by an external input voltage. A VCO’s core can be based on different types of resonators. Single-core VCOs using high quality resonators offer a low phase noise performance over a limited frequency range, whereas the oscillators designed for lower quality target a wideband operation with mediocre noise characteristics. Multiband VCOs using several switched high quality resonator circuits offer an alternative solution by providing wideband operation and low phase noise performance, which is, however, achieved at the expense of a slower tuning speed limited by the time required to switch between different cores. VCOs are usually used in conjunction with phase-locked loops.</p><p>A phase-locked loop (PLL) or PLL synthesizer is a circuit that ensures the stability of a VCO output frequency required in many frequency synthesis and clock recovery applications. As depicted in <strong>Figure 2a</strong>, a PLL incorporates a phase detector that compares a divide-by-N version of the VCO frequency to the reference frequency and uses this difference output signal to adjust the DC control voltage applied to the tuning line of the VCO. This allows for instantaneous correction of any frequency drift and thus maintains stable operation of the oscillator. A typical PLL IC includes an error detector—a phase frequency detector (PFD) with a charge pump—and a feedback divider (see dashed line area in <strong>Figure 2a</strong>), and it still requires an additional external loop filter, a reference frequency, and a VCO to form a complete feedback system for stable frequency generation. The realization of this system can be significantly simplified by using synthesizer ICs featuring an integrated VCO.<sup>1</sup></p><div class="wp-block-image"><figure class="aligncenter size-large"><img loading="lazy" width="1024" height="554" src="https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-02-1024x554.jpg" alt="" class="wp-image-20988" srcset="https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-02-1024x554.jpg 1024w, https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-02-300x162.jpg 300w, https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-02-768x416.jpg 768w, https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-02-1536x831.jpg 1536w, https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-02-367x200.jpg 367w, https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-02.jpg 2025w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption>Figure 2: Simplified block diagrams of the (a) phase-locked loop, (b) translation loop, and (c) direct digital synthesizer</figcaption></figure></div><p>Synthesizers with integrated VCO combine a PLL and a VCO in a single package and require only an external reference and a loop filter to realize the desired function. An integrated PLL synthesizer is a versatile solution with a broad spectrum of digital control settings for accurate frequency generation. It may often include integrated power splitters, frequency multipliers, frequency dividers, and tracking filters to permit up to several octaves of frequency coverage beyond the fundamental range of the integrated VCO. Intrinsic parameters of all these components determine output frequency range, phase noise, jitter, lock time, and other characteristics representing overall performance of the synthesizer circuit.</p><p>A translation loop is another type of synthesizer solution based on the PLL concept but implemented using a different approach. As shown in <strong>Figure 2b</strong>, it uses an integrated downconversion mixing stage instead of an N-divider in the feedback loop to set the loop gain to 1 and minimize the in-band phase noise. Translation loop ICs (see the dashed line area in <strong>Figure 2b</strong>) are designed for highly jitter sensitive applications and, in combination with an external PFD and an LO, enable a complete frequency synthesis solution offering an instrument-grade performance in a compact form factor.</p><p>A direct digital synthesis (DDS) IC is an alternative to integrated PLL synthesizers, and realized using a different concept. The basic DDS architecture is schematically depicted in <strong>Figure 2c</strong>. It is a digitally controlled system that includes a highly accurate reference frequency representing a clock signal, a numerically controlled oscillator (NCO) creating a digital version of the target waveform, and a digital-to-analog converter (DAC) delivering the final analog output. DDS ICs offer rapid hopping speeds, fine tuning resolution of the frequency and phase, and low output distortion, which makes them an ideal solution for applications where superior noise performance and high frequency agility are of primary importance.<sup>2</sup></p><p>Frequency generation components find their use in a broad range of applications that impose different requirements on their performance. For example, communication systems require low in-band noise to maintain low error vector magnitude (EVM), spectrum analyzers rely on local oscillators with fast lock time to realize rapid frequency sweep, and high speed converters need a low jitter clock to ensure high SNR performance.</p><p><strong>Frequency Multipliers</strong></p><p>Frequency multipliers enable the generation of higher frequencies when fundamental frequency oscillators cannot be used to cover the desired range. These components exploit nonlinear properties of their elements to produce an output signal whose frequency is a harmonic of an input signal. Depending on the order of the target output harmonic, we can distinguish between doublers, triplers, and quadruplers as well as multipliers of higher orders.</p><p>Different types of nonlinear elements used to achieve frequency multiplication allow us to distinguish between passive multipliers relying on diode circuits and active multipliers utilizing transistors. Active multipliers require an external DC bias, but they offer a number of significant advantages over passive devices, including conversion gain, lower input drive levels, and better suppression of the fundamental and spurious frequencies.</p><p>Frequency multiplier ICs are widely used, particularly in conjunction with VCOs, in PLL synthesizer designs or as a part of a local oscillator signal path, offering a simple and inexpensive solution to increase frequencies. However, all types of frequency multipliers suffer from the same disadvantage: they degrade phase noise by at least 20log(N) dB, where N is a multiplication factor. For example, a doubler will increase the phase noise level by at least 6 dB, which can be critical in high speed converter clocking and other phase noise and jitter sensitive applications.<sup>3</sup></p><p><strong>Frequency Dividers and Prescalers</strong></p><p>Frequency dividers transform a higher input frequency into a lower output frequency. Nowadays the great majority of these types of components are digital circuits realized using binary counters or shift registers. They are widely incorporated in clock distribution circuits and PLL synthesizer designs, finding their use in many applications. Frequency dividers can have a fixed divide ratio (such dividers are also known as prescalers) or a programmable divide ratio. Frequency division by a divide ratio of N improves the phase noise of the output signal by 20log(N) dB. However, this improvement is limited by the additive phase of a frequency divider itself, which originates within its active circuitry and adds up to its output. A good frequency divider has low additive phase, which, along with a low harmonic content, is among some of its key characteristics.</p><p><strong>RF Mixers</strong></p><p>An RF mixer in its basic form is a 3-port component that uses a nonlinear or time-varying element to produce an output signal containing the sum and difference frequencies of two input signals. We can generally distinguish between passive and active mixers. Passive mixers use a diode element, or a FET transistor operated as a switch, while active mixers rely on transistor-based circuits to achieve frequency conversion. Passive mixers can offer wide bandwidth and high linearity performance, do not require an external DC bias, and have generally better noise figure than active mixers. However, passive mixers exhibit conversion loss and depend upon high LO input power, as opposed to active mixers that provide gain and require significantly lower LO drive levels. Alternative designs realized as a downconverter or upconverter can combine a passive mixer core and an active circuitry to achieve conversion gain without compromising on NF and linearity.<sup>4</sup></p><p>Mixer ICs can come in a variety of different designs, the most basic being the single-ended (or unbalanced). A conceptual topology of a diode-based single-ended mixer is shown in <strong>Figure 3a</strong>. Single-ended mixers use only one nonlinear element to accomplish frequency conversion, which provides a simple solution but limited performance due to poor isolation between the ports and high level of spurs. Balanced mixer designs overcome those limitations by utilizing symmetrical properties of their circuits. Depending on the degree of symmetry, balanced mixers can be classified into single balanced, double balanced, and triple balanced. Single balanced mixers (see <strong>Figure 3b</strong>) consist of two unbalanced mixers combined with either 90° or 180° hybrid. This type of mixer provides high LO-RF isolation, suppression of RF or LO signal, and rejection of even LO harmonics in the output. Further improvement in performance can be achieved with various types of double balanced mixers. A common example, shown in <strong>Figure 3c</strong>, uses four Schottky diodes in a quad ring configuration with hybrids placed at both RF and LO ports. Double balanced mixers offer high overall performance, which makes them a widely used type of RF mixer IC, as they provide good port-to-port isolation, rejection of both RF and LO frequencies, and suppression of all even RF and LO harmonics.<sup>5</sup> Higher isolation and linearity can be achieved with triple balanced mixers. This type of mixer combines two double balanced designs, forming a higher degree of symmetry to optimize the frequency conversion process, however, at the cost of a significantly increased circuit complexity.</p><div class="wp-block-image"><figure class="aligncenter size-large"><img loading="lazy" width="1024" height="427" src="https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-03-1024x427.jpg" alt="" class="wp-image-20989" srcset="https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-03-1024x427.jpg 1024w, https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-03-300x125.jpg 300w, https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-03-768x320.jpg 768w, https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-03-1536x641.jpg 1536w, https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-03-2048x854.jpg 2048w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption>Figure 3: Conceptual topology of a (a) single ended, (b) single balanced, (c) double balanced, and (d) image reject mixer</figcaption></figure></div><p>In-phase quadrature (I/Q) mixers represent a separate category of balanced designs. I/Q mixers exploit phase cancellation to eliminate unwanted image signals without external filtering. An ordinary I/Q mixer can usually be operated as an image reject mixer (IRM) in a downconversion mode (see <strong>Figure 3d</strong>) or as a single sideband (SSB) mixer in an upconversion mode. The I/Q mixers featuring integrated buffer and driver amplifiers are designed for one of the two operational modes only, which classifies them into I/Q downconverters and I/Q upconverters. These mixers are closely related to another type of frequency conversion ICs known as I/Q modulators and I/Q demodulators. I/Q modulators and I/Q demodulators offer a high impedance differential baseband interface designed to be used with data converters, which makes them ideally suited for direct conversion transceiver applications. In particular, they constitute the core of modern highly integrated RF transceiver ICs.<sup>6</sup></p><p>Another common example of a mixer type that we should briefly mention is a subharmonic mixer. It incorporates a subharmonically pumped local oscillator, providing a simple solution for the realization of high frequency RF designs using lower LO frequencies without an external frequency multiplier.</p><p>There are many other types of RF mixer implementations relying on active and passive technologies. RF mixer ICs can use sophisticated architectures incorporating various components, including PLL/VCO, amplifiers, frequency multipliers, attenuators, and detectors in one package, and provide digital interface to control their functionality.</p><p><strong>RF Filters</strong></p><p>RF filter ICs find their use in virtually every RF application to select the desired frequencies in the spectrum content, which usually also includes unwanted spurious components generated within a nonlinear signal chain and out-of-band signals originating from outside. The key function of the filter is thus to provide a minimum attenuation for pass-band frequencies of interest, and a maximum attenuation for stop-band frequencies to suppress undesired signals. Common types of filter frequency responses depicted in <strong>Figure 4</strong> include a low-pass filter (LPF), high-pass filter (HPF), band-pass filter (BPF), and band-reject filter or band-stop filter (also called a notch filter if its stop band is narrow).</p><p>Most RF applications require filtering across multiple frequency bands, which can be realized using switched filter banks. This type of solution, which incorporates switches and fixed bandwidth filters in one module, can be designed to deliver excellent performance in terms of stop-band rejection, linear dynamic range, and switching speeds. However, conventional switched filter banks have limited band selection capabilities, and they are typically large and costly. Compact tunable filter ICs featuring continuous analog or digital tuning function overcome those limitations, which makes them an attractive alternative to switched fixed filter banks for multiband operation in many applications. Analog tunable filters provide voltage control for adjustment of center and/or cutoff frequencies, whereas the desired characteristic of digital tunable filters can be configured via digital control interface. Tunable filters can offer exceptional pass-band characteristics, good stop-band rejection, wide tuning ranges, and fast settling times to meet the demanding requirements of a broad range of today’s RF applications.</p><div class="wp-block-image"><figure class="aligncenter size-large"><img loading="lazy" width="1024" height="818" src="https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-04-1024x818.jpg" alt="" class="wp-image-20990" srcset="https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-04-1024x818.jpg 1024w, https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-04-300x240.jpg 300w, https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-04-768x613.jpg 768w, https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-04-1536x1226.jpg 1536w, https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-04-375x300.jpg 375w, https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-04.jpg 1850w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption>Figure 4: Filter frequency responses: (a) low-pass filter, (b) high-pass filter, (c) band-pass filter, and (d) band-stop filter</figcaption></figure></div><p><strong>RF Switches</strong></p><p>An RF switch is a control component used to route high frequency signals through the signal chain. Its key function can be realized with different types of switching elements, including PIN diodes, FET transistors, or micromachined cantilever beams. Depending on how the switching elements are arranged, the switch design can have a different number of poles (separate circuits controlled by the switch) and throws (separate output paths the switch can adopt for each pole). Single-pole, n-throw (SPnT) switches route signals from one input to n outputs. For example a single-pole, single-throw (SPST) switch connects one input to one output, providing a simple on-off functionality; a single-pole, double-throw (SPDT) switch toggles one input with two outputs (see <strong>Figure 5a</strong>); and a single-pole, four-throw (SP4T) switch routes the input signal to four output paths (see <strong>Figure 5b</strong>). RF switches can also have multiple poles, and this type of switch is called a transfer switch (see <strong>Figure 5c</strong>). The most common example is a double-pole, double-throw (DPDT) configuration with two separate circuits that can be connected to one of the two output paths.</p><div class="wp-block-image"><figure class="aligncenter size-large"><img loading="lazy" width="1024" height="772" src="https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-05-1024x772.jpg" alt="" class="wp-image-20991" srcset="https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-05-1024x772.jpg 1024w, https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-05-300x226.jpg 300w, https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-05-768x579.jpg 768w, https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-05-380x285.jpg 380w, https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-05-94x72.jpg 94w, https://www.mpdigest.com/wp-content/uploads/2021/09/370452-fig-05.jpg 1032w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption>Figure 5: Examples of RF switches: (a) absorptive SPDT, (b) reflective SP4T, and (c) control transfer switch with a truth table example (Note: RFC = RF common port, CTRL = control voltage port)</figcaption></figure></div><p>RF switch designs can have more complex topologies combining multiple switches of a lower order. These ICs are known as switch matrix or crosspoint switches. They provide flexible routing of RF signals between multiple inputs and multiple outputs.</p><p>Regardless of the switch configuration, we can generally distinguish between reflective switches and absorptive switches (also known as nonreflective or terminated switches). The main difference between them is that the absorptive switches incorporate a matched load used to terminate output ports in off-state to minimize voltage standing-wave ratio (VSWR) (see <strong>Figure 5a</strong>). This feature allows the absorptive switches to maintain good return loss in both switch modes, which is something reflective switches cannot offer. However, this advantage of absorptive switches comes at the cost of their lower power handling capability and higher circuit complexity compared to reflective switches.</p><p>RF switch ICs can be implemented in a number of different technologies, including silicon-based semiconductors CMOS and SOI, compound semiconductors GaAs and GaN, and microelectromechanical systems (MEMS).<sup>7,8</sup> Each technology offers various trade-offs between key performance specifications such as frequency range, power handing capability, isolation, insertion loss, switching speed, and settling time. For example, GaAs is preferable for high temperature performance, GaN is widely used in high power applications, and the silicon-based process prevails in settling time, integration capabilities, lower frequency characteristics, and higher ESD robustness.<sup>7</sup> The alternative MEMS technology offers a micromechanical relay in a small chip scale package. It uniquely enables DC precision performance with high linearity and power, trading off switching speed, finite cycle lifetimes, and hot-switching limits.</p><p><strong>RF Attenuators</strong></p><p>An RF attenuator reduces the strength of RF signals, and thus fulfills the opposite function of an amplifier. It is a control component used to adjust gain and balance signal levels in the signal chain. RF attenuator ICs are typically absorptive (transmission-type) devices. We can generally distinguish between fixed attenuators, which have an unchanging attenuation level, and variable attenuators, which allow its adjustment. Variable attenuator ICs featuring a set of discrete attenuation levels are called digital step attenuators (DSAs), and they are usually employed for coarse signal calibration, which is limited by the predetermined attenuation step size. For fine signal control, voltage variable attenuators (VVAs) are used. As opposed to DSAs, VVAs offer continuous adjustment of the attenuation level, which can be set to any value within the given range. All types of RF attenuators should deliver flat attenuation performance with good VSWR across the operational frequency range, while the DSAs must also ensure glitch-free operation to reduce signal distortions during state transitions.⁷</p><p><strong>RF Detectors</strong></p><p>An integrated RF detector in its basic form is a 2-port device providing an output voltage signal proportional to the RF signal power applied to its input. As opposed to discrete diode-based detector implementations, integrated RF detectors offer a number of out-of-the-box advantages, including stable output voltage over wide temperature range, easier device calibration, and a buffered output for a direct interface with an ADC.<sup>9</sup> Most common RF detector ICs are scalar detectors utilized for a broad variety of applications where measurement of RF signal power magnitude is required. The main types of scalar detectors include RMS power detectors, logarithmic detectors, and envelope detectors.</p><p>RMS power detectors provide an accurate RMS representation of the real signal power applied to the RF input. There are RMS detectors with a linear response, whose RMS output is a linear-responding DC voltage, and logarithmic RMS detectors with a “linear in dB” response, whose output voltage changes by the same amount for every dB change in true RF input power. Both types of RMS detectors are ideally suited for waveform independent power measurement of complex modulated signals with high crest factor changing over time in applications that do not require fast response time performance. They are typically used for average power monitoring, transmitter signal strength indication (TSSI), received signal strength indication (RSSI), and automatic gain control (AGC).</p><p>Logarithmic detectors (also known as logarithmic amplifiers) convert an input RF signal to an accurate log-linear DC output voltage. Log detectors offer a very high dynamic range operation. This is achieved using a successive compression approach, which relies on a cascade of limiting amplifiers coupled to detectors whose outputs are summed at the output stage of the cascaded topology. As the input power increases, successive amplifiers move into saturation one by one, thus creating an approximation of the logarithm function. Log detectors are very well suited for high dynamic range applications including RSSI and RF input protection.</p><p>A successive detection logarithmic video amplifier (SDLVA) is a special type of logarithmic detector that offers flat frequency response and superior rise/fall and delay times, which makes it the solution of choice for applications demanding very high speed performance, including instantaneous frequency measurement, direction finding receivers, and electronic intelligence applications.</p><p>Envelope detectors (also known as peak detectors or AM detectors) provide a baseband output voltage proportional to the instantaneous amplitude of the RF input signal. Envelope detector ICs are usually realized using fast switching Schottky diodes, which makes them an ideal solution for lower dynamic range applications requiring very fast response times. Typical applications of envelope detectors include efficiency enhancing envelope tracking in PA bias control, PA linearization, fast excessive RF power protection, high resolution pulse detection, and LO leakage correction of I/Q modulators.</p><p>Apart from scalar detectors, we can also recognize another category of integrated detectors known as vector power measurement ICs. They offer extended capabilities going beyond scalar power measurement functionality.<sup>10 </sup>Vector power measurement detectors can measure multiple parameters of a signal, including its magnitude, phase, and traveling direction along the transmission path (forward and reverse). This type of device is an ideal solution for inline measurement of scattering parameters in numerous applications, including antenna tuning in wireless transmitters, built-in test in modular systems, and materials analysis.</p><p><strong>Conclusion</strong></p><p>In the second part of our RF signal chain discourse we discussed and classified some of the key RF ICs representing essential building blocks of a typical RF signal chain. However, in this overview we have only scratched the surface of the multifaceted diversity of types and forms of RF components. Increasing complexity of RF systems requires more complete signal chain solutions, which results in development of numerous IC designs consolidating multiple functional blocks in the same package or on one die. These devices can integrate mixers, PLLs, VCOs, amplifiers, detectors, and other components to deliver significantly advanced functionality in a compact form factor and offer simpler designs, reduced power consumption, lower cost, and shorter development cycles.</p><p>Analog Devices provides the broadest portfolio of RF integrated circuits in the industry, covering the complete frequency spectrum from DC to beyond 100 GHz and fitting nearly all of the functional blocks in a signal chain.<sup>11</sup> The widest array of ADI offerings spans from amplifiers, mixers, filters, and other standard IC components, all the way through mixed-signal analog front ends and system-in-package (SiP) solutions, which are fully tested and verified as complete subsystems. ADI products deliver best-in-class performance and address the most demanding requirements across a wide variety of RF applications ranging from communication and industrial systems, all the way up to test and measurement equipment and aerospace systems. To support RF engineers in the development process of these applications, ADI provides not only RF ICs but also an entire ecosystem including design tools, rapid prototyping platforms, Circuits from the Lab® reference designs, EngineerZone® technical forums, and world-class technical support.</p><p><strong>References</strong></p><p>1 Ian Collins and David Mailloux. “Revolution and Evolution in Frequency Synthesis: How PLL/VCO Technology Has Increased Performance, Decreased Size, and Simplified Design Cycle.” Analog Devices, Inc., January 2020.</p><p>2 Jim Surber and Leo McHugh. “Single-Chip Direct Digital Synthesis vs. the Analog PLL.” Analog Dialogue, Vol. 30, No. 3, July 1996.</p><p>3 Hittite Microwave Corp. “Active Multipliers and Dividers to Simplify Synthesizers.” Microwave Journal, November 2002.</p><p>4 Thomas Schiltz, Bill Beckwith, Dong Wang, and Doug Stuetzle. “Passive Mixers Increase Gain and Decrease Noise When Compared to Active Mixers in Downconverter Applications.” Analog Devices, Inc., October 2010.</p><p>5 David M. Pozar. Microwave Engineering, 4th edition, Wiley, 2011.</p><p>6 Abhishek Kapoor and Assaf Toledano. “The Changing Landscape of Frequency Mixing Components.” Analog Devices, Inc., September 2016.</p><p>7 Bilge Bayrakci. “RF and MW Control Products in Silicon.” Analog Devices, Inc., March 2016.</p><p>8 Eric Carty, Padraig Fitzgerald, and Padraig McDaid. “The Fundamentals of Analog Devices’ Revolutionary MEMS Switch Technology.” Analog Devices, Inc., November 2016.</p><p>9 Eamon Nash. “Understanding, Operating, and Interfacing to Integrated Diode-Based RF Detectors.” Analog Devices, Inc., November 2015.</p><p>10 Eamon Nash and Eberhard Brunner. “An Integrated Bidirectional Bridge with Dual RMS Detectors for RF Power and Return-Loss Measurement.” Analog Dialogue, Vol. 52, No. 2, May 2018.</p><p>11 “RF, Microwave, and Millimeter Wave Products Selection Guide 2020.” Analog Devices, Inc., August 2020.</p><p><strong>About the Author</strong></p><p>Anton Patyuchenko received his Master of Science in microwave engineering from the Technical University of Munich in 2007. Following his graduation, Anton worked as a scientist at German Aerospace Center (DLR). He joined Analog Devices as a field applications engineer in 2015 and is currently providing field applications support to strategic and key customers of Analog Devices specializing in RF applications. He can be reached at anton.patyuchenko@analog.com.</p><p class="bawpvc-ajax-counter" data-id="20993"> (20)</p><div class="h5ab-print-button-container"><div class="h5ab-print-button h5ab-print-button-right" style="cursor: pointer; color: #555"><i class="fa fa-print fa-lg"></i> <span>print</span></div></div><div class='yarpp yarpp-related yarpp-related-website yarpp-template-list'> <!-- YARPP List --><h3>Related posts:</h3><ol><li><a href="https://www.mpdigest.com/2016/04/25/wideband-high-dynamic-range-limiting-amplifier/" rel="bookmark" title="Wideband High Dynamic Range Limiting Amplifier">Wideband High Dynamic Range Limiting Amplifier </a></li><li><a href="https://www.mpdigest.com/2016/09/22/the-changing-landscape-of-frequency-mixing-components/" rel="bookmark" title="The Changing Landscape of Frequency Mixing Components">The Changing Landscape of Frequency Mixing Components </a></li><li><a href="https://www.mpdigest.com/2017/09/21/transmit-lo-leakage-lol-an-issue-of-zero-if-that-isnt-making-people-laugh-out-loud/" rel="bookmark" title="Transmit LO Leakage (LOL)—an Issue of Zero-IF that Isn’t Making People Laugh Out Loud">Transmit LO Leakage (LOL)—an Issue of Zero-IF that Isn’t Making People Laugh Out Loud </a></li><li><a href="https://www.mpdigest.com/2019/01/29/rf-transceivers-enable-forced-spurious-decorrelation-in-digital-beamforming-phased-arrays/" rel="bookmark" title="RF Transceivers Enable Forced Spurious Decorrelation in Digital Beamforming Phased Arrays">RF Transceivers Enable Forced Spurious Decorrelation in Digital Beamforming Phased Arrays </a></li></ol></div></div><!-- .entry-content --><div class='ad ads_single_bottom'><div id="google-ads-835"></div> <script type="text/javascript"> /* Calculate the width of available ad space */
 ad = document.getElementById('google-ads-835'); 
 if (ad.getBoundingClientRect().width) {
 adWidth = ad.getBoundingClientRect().width; // for modern browsers
 } else {
 adWidth = ad.offsetWidth; // for old IE
 } 
 /* Replace ca-pub-XXX with your AdSense Publisher ID */
 google_ad_client = 'pub-8079202658536112'; 
 /* Replace 1234567890 with the AdSense Ad Slot ID */
 google_ad_slot = 'pub-8079202658536112';  /* Do not change anything after this line */
 if ( adWidth >= 728 )
 google_ad_size = ["728", "90"]; /* Leaderboard 728x90 */
 else if ( adWidth >= 468 )
 google_ad_size = ["468", "60"]; /* Banner (468 x 60) */
 else if ( adWidth >= 336 )
 google_ad_size = ["336", "280"]; /* Large Rectangle (336 x 280) */
 else if ( adWidth >= 300 )
 google_ad_size = ["300", "250"]; /* Medium Rectangle (300 x 250) */
 else if ( adWidth >= 250 )
 google_ad_size = ["250", "250"]; /* Square (250 x 250) */
 else if ( adWidth >= 200 )
 google_ad_size = ["200", "200"]; /* Small Square (200 x 200) */
 else if ( adWidth >= 180 )
 google_ad_size = ["180", "150"]; /* Small Rectangle (180 x 150) */
 else
 google_ad_size = ["125", "125"]; /* Button (125 x 125) */ 
 document.write (
 '<ins class="adsbygoogle" style="display:inline-block;width:'
 + google_ad_size[0] + 'px;height:'
 + google_ad_size[1] + 'px" data-ad-client="'
 + google_ad_client + '" data-ad-slot="'
 + google_ad_slot + '"></ins>'
 );
 (adsbygoogle = window.adsbygoogle || []).push({}); </script> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"> </script></div><div class="tag-group"> <span>tags:</span> <a href="https://www.mpdigest.com/tag/analog-devices-inc/" rel="tag">Analog Devices Inc.</a></div> <!--navigation post--><div class="cactus-navigation-post"><div class="prev-post"> <a href="https://www.mpdigest.com/2021/09/24/the-perils-of-pim-remain-a-problem-for-antennas-too/" title="The Perils of PIM Remain a Problem... for Antennas, Too"> <span>previous</span> The Perils of PIM Remain a Problem... for Antennas, Too </a></div></div> <!--navigation post--> <!--Author--><div class="cactus-author-post"><div class="cactus-author-pic"><div class="img-content"> <a href="https://www.mpdigest.com/author/admin/" class="avatar"> <img alt='' src='https://secure.gravatar.com/avatar/8455610c26636fea951ff1aa0b752b4a?s=110&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/8455610c26636fea951ff1aa0b752b4a?s=220&#038;d=mm&#038;r=g 2x' class='avatar avatar-110 photo' height='110' width='110' loading='lazy'/> </a></div></div><div class="cactus-author-content"><div class="author-content"> <span class="author-name"><a href="https://www.mpdigest.com/author/admin/">mpdigest</a></span> <span class="author-body"></span><ul class="social-listing list-inline"></ul></div></div></div> <!--Author--> <!--related post--><div class="cactus-related-posts"><div class="title-related-post"> Related Posts <a class="pre-carousel" href="javascript:;"><i class="fa fa-angle-left"></i></a> <a class="next-carousel" href="javascript:;"><i class="fa fa-angle-right"></i></a><div class="pagination"></div></div><div class="related-posts-content"> <!--Listing--><div class="cactus-listing-wrap"> <!--Config--><div class="cactus-listing-config style-1 style-3"> <!--addClass: style-1 + (style-2 -> style-n)--><div class="container"><div class="row"><div class="col-md-12 cactus-listing-content"> <!--ajax div--><div class="cactus-sub-wrap"><div class="cactus-swiper-container" data-settings='["mode":"cactus-fix-composer"]'><div class="swiper-wrapper"><div class="swiper-slide"> <!--item listing--><div class="cactus-post-item hentry"> <!--content--><div class="entry-content"><div class="primary-post-content"> <!--addClass: related-post, no-picture --> <!--picture--><div class="picture"><div class="picture-content"> <a href="https://www.mpdigest.com/2016/04/25/wideband-high-dynamic-range-limiting-amplifier/" title="Wideband High Dynamic Range Limiting Amplifier"><div class="thumb-overlay"></div> </a></div></div><!--picture--><div class="content"> <!--Title--><h3 class="h6 cactus-post-title entry-title"> <a href="https://www.mpdigest.com/2016/04/25/wideband-high-dynamic-range-limiting-amplifier/" title="Wideband High Dynamic Range Limiting Amplifier">Wideband High Dynamic Range Limiting Amplifier</a></h3><!--Title--> <!--info--><div class="posted-on"> <a href="https://www.mpdigest.com/2016/04/25/wideband-high-dynamic-range-limiting-amplifier/" class="cactus-info" rel="bookmark"><time datetime="2016-04-25T08:20:41-04:00" class="entry-date updated">April 25, 2016</time></a> <span class="vcard author"> <span class="fn"><a href="https://www.mpdigest.com/author/admin/" class="author cactus-info">mpdigest</a></span> </span> <a href="https://www.mpdigest.com/2021/09/27/rf-signal-chain-discourse-part-2-essential-building-blocks/#respond" class="comment cactus-info">0</a></div><!--info--><div class="cactus-last-child"></div> <!--fix pixel no remove--></div></div></div><!--content--></div><!--item listing--></div><div class="swiper-slide"> <!--item listing--><div class="cactus-post-item hentry"> <!--content--><div class="entry-content"><div class="primary-post-content"> <!--addClass: related-post, no-picture --> <!--picture--><div class="picture"><div class="picture-content"> <a href="https://www.mpdigest.com/2016/09/22/the-changing-landscape-of-frequency-mixing-components/" title="The Changing Landscape of Frequency Mixing Components"><div class="thumb-overlay"></div> </a></div></div><!--picture--><div class="content"> <!--Title--><h3 class="h6 cactus-post-title entry-title"> <a href="https://www.mpdigest.com/2016/09/22/the-changing-landscape-of-frequency-mixing-components/" title="The Changing Landscape of Frequency Mixing Components">The Changing Landscape of Frequency Mixing Components</a></h3><!--Title--> <!--info--><div class="posted-on"> <a href="https://www.mpdigest.com/2016/09/22/the-changing-landscape-of-frequency-mixing-components/" class="cactus-info" rel="bookmark"><time datetime="2016-09-22T06:45:00-04:00" class="entry-date updated">September 22, 2016</time></a> <span class="vcard author"> <span class="fn"><a href="https://www.mpdigest.com/author/admin/" class="author cactus-info">mpdigest</a></span> </span> <a href="https://www.mpdigest.com/2021/09/27/rf-signal-chain-discourse-part-2-essential-building-blocks/#respond" class="comment cactus-info">0</a></div><!--info--><div class="cactus-last-child"></div> <!--fix pixel no remove--></div></div></div><!--content--></div><!--item listing--></div><div class="swiper-slide"> <!--item listing--><div class="cactus-post-item hentry"> <!--content--><div class="entry-content"><div class="primary-post-content"> <!--addClass: related-post, no-picture --> <!--picture--><div class="picture"><div class="picture-content"> <a href="https://www.mpdigest.com/2017/09/21/transmit-lo-leakage-lol-an-issue-of-zero-if-that-isnt-making-people-laugh-out-loud/" title="Transmit LO Leakage (LOL)—an Issue of Zero-IF that Isn’t Making People Laugh Out Loud"><div class="thumb-overlay"></div> </a></div></div><!--picture--><div class="content"> <!--Title--><h3 class="h6 cactus-post-title entry-title"> <a href="https://www.mpdigest.com/2017/09/21/transmit-lo-leakage-lol-an-issue-of-zero-if-that-isnt-making-people-laugh-out-loud/" title="Transmit LO Leakage (LOL)—an Issue of Zero-IF that Isn’t Making People Laugh Out Loud">Transmit LO Leakage (LOL)—an Issue of Zero-IF that Isn’t Making People Laugh Out Loud</a></h3><!--Title--> <!--info--><div class="posted-on"> <a href="https://www.mpdigest.com/2017/09/21/transmit-lo-leakage-lol-an-issue-of-zero-if-that-isnt-making-people-laugh-out-loud/" class="cactus-info" rel="bookmark"><time datetime="2017-09-21T07:00:11-04:00" class="entry-date updated">September 21, 2017</time></a> <span class="vcard author"> <span class="fn"><a href="https://www.mpdigest.com/author/admin/" class="author cactus-info">mpdigest</a></span> </span> <a href="https://www.mpdigest.com/2021/09/27/rf-signal-chain-discourse-part-2-essential-building-blocks/#respond" class="comment cactus-info">0</a></div><!--info--><div class="cactus-last-child"></div> <!--fix pixel no remove--></div></div></div><!--content--></div><!--item listing--></div></div></div></div></div></div></div></div><!--Config--></div><!--Listing--></div></div> <!--related post--><div id="comments" class="comments-area"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">LEAVE YOUR COMMENT <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/09/27/rf-signal-chain-discourse-part-2-essential-building-blocks/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="https://www.mpdigest.com/wp-login.php?redirect_to=https%3A%2F%2Fwww.mpdigest.com%2F2021%2F09%2F27%2Frf-signal-chain-discourse-part-2-essential-building-blocks%2F">logged in</a> to post a comment.</p></div><!-- #respond --></div><!-- #comments --></article></div><div class="content-bottom-sidebar-wrap"><div id="adrotate_widgets-3" class="body-widget adrotate_widgets"><div class="body-widget-inner"><div class="a-single a-71"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <!-- Front Page - filler --> <ins class="adsbygoogle"
 style="display:block"
 data-ad-client="ca-pub-8079202658536112"
 data-ad-slot="1082845189"
 data-ad-format="auto"
 data-full-width-responsive="true"></ins> <script> (adsbygoogle = window.adsbygoogle || []).push({}); </script></div></div></div></div></div> <!--Sidebar--><div class="col-md-4 cactus-sidebar main-sidebar-col"> <!--addClass: left / right -> config sidebar position--><div class="sidebar-content-fixed-scroll"><aside id="adrotate_widgets-4" class="widget col-md-12 module widget-col adrotate_widgets"><div class="widget-inner"><!-- Error, Advert is not available at this time due to schedule/geolocation restrictions! --></div></aside><aside id="popular_posts_id-2" class="widget col-md-12 module widget-col popular_posts"><div class="widget-inner"> <style type="text/css"> #popular_posts_id-2 .easy-tab .tabs li.active a,
 #popular_posts_id-2 .widget-title{color:EDC828 !important; background:155AA5 !important}
 #popular_posts_id-2 .easy-tab .tabs li:not(.active) a:hover{color:155AA5 !important}
 #popular_posts_id-2 .easy-tab .tabs li:first-child a:before, .cactus-sidebar popular_posts_id-2.widget .widget-title:before,
 #popular_posts_id-2 .widget-title:before{background:155AA5 !important} </style><h2 class="widget-title h6">In The News</h2><div class="cactus-widget-posts "><div class="cactus-widget-posts-item"><div class="cactus-widget-posts-content"><h3 class="h6 widget-posts-title"> <a href="https://www.mpdigest.com/2021/09/24/infinite-electronics-inc-names-matthias-norweg-for-the-role-of-senior-vice-president-of-corporate-development/" title="Infinite Electronics, Inc. Names Matthias Norweg for the Role of Senior Vice President of Corporate Development">Infinite Electronics, Inc. Names Matthias Norweg for the Role of Senior Vice President of Corporate Development</a></h3><div class="posted-on"> <a href="https://www.mpdigest.com/2021/09/24/infinite-electronics-inc-names-matthias-norweg-for-the-role-of-senior-vice-president-of-corporate-development/" class="cactus-info" rel="bookmark"><time datetime="2021-09-24T10:10:16-04:00" class="entry-date updated">September 24, 2021</time></a><div class="comment cactus-info">0</div></div></div></div><div class="cactus-widget-posts-item"><div class="cactus-widget-posts-content"><h3 class="h6 widget-posts-title"> <a href="https://www.mpdigest.com/2021/09/22/pozyx-appoints-industry-veteran-frans-frielink-as-chairman-of-the-board/" title="Pozyx Appoints Industry Veteran Frans Frielink as Chairman of the Board">Pozyx Appoints Industry Veteran Frans Frielink as Chairman of the Board</a></h3><div class="posted-on"> <a href="https://www.mpdigest.com/2021/09/22/pozyx-appoints-industry-veteran-frans-frielink-as-chairman-of-the-board/" class="cactus-info" rel="bookmark"><time datetime="2021-09-22T11:40:14-04:00" class="entry-date updated">September 22, 2021</time></a><div class="comment cactus-info">0</div></div></div></div><div class="cactus-widget-posts-item"><div class="cactus-widget-posts-content"><h3 class="h6 widget-posts-title"> <a href="https://www.mpdigest.com/2021/09/22/donald-mcelheny-retires-from-gowanda-electronics-after-24-years/" title="Donald McElheny Retires from Gowanda Electronics after 24 Years">Donald McElheny Retires from Gowanda Electronics after 24 Years</a></h3><div class="posted-on"> <a href="https://www.mpdigest.com/2021/09/22/donald-mcelheny-retires-from-gowanda-electronics-after-24-years/" class="cactus-info" rel="bookmark"><time datetime="2021-09-22T11:34:08-04:00" class="entry-date updated">September 22, 2021</time></a><div class="comment cactus-info">0</div></div></div></div></div></div></aside><aside id="adrotate_widgets-2" class="widget col-md-12 module widget-col adrotate_widgets"><div class="widget-inner"><!-- Either there are no banners, they are disabled or none qualified for this location! --></div></aside><aside id="black-studio-tinymce-14" class="widget col-md-12 module widget-col widget_black_studio_tinymce"><div class="widget-inner"><div class="textwidget"><hr style="border-color:#edc828;"></div></div></aside><aside id="categories-2" class="widget col-md-12 module widget-col widget_categories"><div class="widget-inner"> <style type="text/css"> #categories-2 .easy-tab .tabs li.active a,
 #categories-2 .widget-title{color:EDC828 !important; background:155AA5 !important}
 #categories-2 .easy-tab .tabs li:not(.active) a:hover{color:155AA5 !important}
 #categories-2 .easy-tab .tabs li:first-child a:before, .cactus-sidebar categories-2.widget .widget-title:before,
 #categories-2 .widget-title:before{background:155AA5 !important} </style><h2 class="widget-title h6">Categories</h2><ul><li class="cat-item cat-item-6"><a href="https://www.mpdigest.com/category/blog/" title="Small timely articles and information about the microwave product industry.">Blog</a></li><li class="cat-item cat-item-8"><a href="https://www.mpdigest.com/category/cover-products/" title="Featured products from the cover of each Microwave Product Digest monthly issue.">Cover Products</a></li><li class="cat-item cat-item-4"><a href="https://www.mpdigest.com/category/featured-articles/" title="Featured articles related to the microwave industry.">Featured Articles</a></li><li class="cat-item cat-item-7"><a href="https://www.mpdigest.com/category/in-the-news/" title="Trending and current news features about the microwave product industry.">In The News</a></li><li class="cat-item cat-item-720"><a href="https://www.mpdigest.com/category/featured-articles/military-article/">Military Article</a></li><li class="cat-item cat-item-3"><a href="https://www.mpdigest.com/category/military-products/" title="New products for the microwave industry military market.">Military Products</a></li><li class="cat-item cat-item-2"><a href="https://www.mpdigest.com/category/on-the-market/" title="New products in the microwave industry.">On The Market</a></li><li class="cat-item cat-item-5"><a href="https://www.mpdigest.com/category/opinion/" title="Opinion pieces by those in the microwave industry.">Opinion</a></li><li class="cat-item cat-item-68"><a href="https://www.mpdigest.com/category/featured-articles/view-from-the-top/">View From the Top</a></li></ul></div></aside><aside id="recent-posts-2" class="widget col-md-12 module widget-col widget_recent_entries"><div class="widget-inner"> <style type="text/css"> #recent-posts-2 .easy-tab .tabs li.active a,
 #recent-posts-2 .widget-title{color:EDC828 !important; background:155AA5 !important}
 #recent-posts-2 .easy-tab .tabs li:not(.active) a:hover{color:155AA5 !important}
 #recent-posts-2 .easy-tab .tabs li:first-child a:before, .cactus-sidebar recent-posts-2.widget .widget-title:before,
 #recent-posts-2 .widget-title:before{background:155AA5 !important} </style><h2 class="widget-title h6">Recent Posts</h2><ul><li> <a href="https://www.mpdigest.com/2021/09/27/monitoring-the-charging-stations-of-the-e-bus-fleet-of-the-city-of-jena/">Monitoring the Charging Stations of the E-bus Fleet of the City of Jena</a></li><li> <a href="https://www.mpdigest.com/2021/09/27/rf-signal-chain-discourse-part-2-essential-building-blocks/" aria-current="page">RF Signal Chain Discourse — Part 2: Essential Building Blocks</a></li><li> <a href="https://www.mpdigest.com/2021/09/27/what-lies-beneath/">What Lies Beneath</a></li><li> <a href="https://www.mpdigest.com/2021/09/24/infinite-electronics-inc-names-matthias-norweg-for-the-role-of-senior-vice-president-of-corporate-development/">Infinite Electronics, Inc. Names Matthias Norweg for the Role of Senior Vice President of Corporate Development</a></li><li> <a href="https://www.mpdigest.com/2021/09/24/the-perils-of-pim-remain-a-problem-for-antennas-too/">The Perils of PIM Remain a Problem&#8230; for Antennas, Too</a></li></ul></div></aside><aside id="black-studio-tinymce-13" class="widget col-md-12 module widget-col widget_black_studio_tinymce"><div class="widget-inner"><div class="textwidget"><!-- Begin MailChimp Signup Form --><link href="//cdn-images.mailchimp.com/embedcode/classic-10_7.css" rel="stylesheet" type="text/css"> <style type="text/css"> #mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif;  width:300px;}
 /* Add your own MailChimp form style overrides in your site stylesheet or in this style block.
 We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */ </style><div id="mc_embed_signup"><form action="//mpdigest.us12.list-manage.com/subscribe/post?u=9951524b0b00734dd903c232e&amp;id=2c361ec420" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate><div id="mc_embed_signup_scroll"><h2>Subscribe to our mailing list</h2><div class="indicates-required"><span class="asterisk">*</span> indicates required</div><div class="mc-field-group"> <label for="mce-EMAIL">Email Address <span class="asterisk">*</span> </label> <input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL"></div><div class="mc-field-group"> <label for="mce-FNAME">First Name </label> <input type="text" value="" name="FNAME" class="" id="mce-FNAME"></div><div class="mc-field-group"> <label for="mce-LNAME">Last Name </label> <input type="text" value="" name="LNAME" class="" id="mce-LNAME"></div><div class="mc-field-group input-group"> <strong>Email Format </strong><ul><li><input type="radio" value="html" name="EMAILTYPE" id="mce-EMAILTYPE-0"><label for="mce-EMAILTYPE-0">html</label></li><li><input type="radio" value="text" name="EMAILTYPE" id="mce-EMAILTYPE-1"><label for="mce-EMAILTYPE-1">text</label></li></ul></div><div id="mce-responses" class="clear"><div class="response" id="mce-error-response" style="display:none"></div><div class="response" id="mce-success-response" style="display:none"></div></div> <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups--><div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_9951524b0b00734dd903c232e_2c361ec420" tabindex="-1" value=""></div><div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div></div></form></div> <!--End mc_embed_signup--></div></div></aside></div></div> <!--Sidebar--></div><!--.row--></div><!--.container--></div><!--#cactus-single-page--></div><!--#cactus-body-container--><div id="ads_walls"><div class="container"><div id='ads_wall_1'><div id="ads_wall_1_in"> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <!-- MPD Wall ad - right --> <ins class="adsbygoogle"
 style="display:inline-block;width:300px;height:600px"
 data-ad-client="ca-pub-8079202658536112"
 data-ad-slot="7184073588"></ins> <script> (adsbygoogle = window.adsbygoogle || []).push({}); </script></div></div><div id='ads_wall_2'> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <!-- MPD Wall ad - right --> <ins class="adsbygoogle"
 style="display:inline-block;width:300px;height:600px"
 data-ad-client="ca-pub-8079202658536112"
 data-ad-slot="7184073588"></ins> <script> (adsbygoogle = window.adsbygoogle || []).push({}); </script></div></div></div><footer><div class="footer-inner dark-div"><div class="footer-sidebar"><div class="container"><div class="row"><aside id="block-2" class="widget col-md-3 module widget-col widget_block"><div class="widget-inner"><p><strong>ADVERTISE WITH US</strong></p><p>Explore the opportunities that advertising with MPD has.<br> <br>Click here to download our <a href="https://www.mpdigest.com/wp-content/uploads/2020/11/Media_Kit_2021_11-30.pdf" style="color: #edc828" target="”_blank”">media guide</a>.<br> <br>Click here to <a href="https://www.mpdigest.com/contact-us/" style="color: #edc828" target="”_blank”">contact us</a>.</p></div></aside><aside id="archives-4" class="widget col-md-3 module widget-col widget_archive"><div class="widget-inner"><h2 class="widget-title h6">Archives</h2> <label class="screen-reader-text" for="archives-dropdown-4">Archives</label> <select id="archives-dropdown-4" name="archive-dropdown"><option value="">Select Month</option><option value='https://www.mpdigest.com/2021/09/'> September 2021</option><option value='https://www.mpdigest.com/2021/08/'> August 2021</option><option value='https://www.mpdigest.com/2021/07/'> July 2021</option><option value='https://www.mpdigest.com/2021/06/'> June 2021</option><option value='https://www.mpdigest.com/2021/05/'> May 2021</option><option value='https://www.mpdigest.com/2021/04/'> April 2021</option><option value='https://www.mpdigest.com/2021/03/'> March 2021</option><option value='https://www.mpdigest.com/2021/02/'> February 2021</option><option value='https://www.mpdigest.com/2021/01/'> January 2021</option><option value='https://www.mpdigest.com/2020/12/'> December 2020</option><option value='https://www.mpdigest.com/2020/11/'> November 2020</option><option value='https://www.mpdigest.com/2020/10/'> October 2020</option><option value='https://www.mpdigest.com/2020/09/'> September 2020</option><option value='https://www.mpdigest.com/2020/08/'> August 2020</option><option value='https://www.mpdigest.com/2020/07/'> July 2020</option><option value='https://www.mpdigest.com/2020/06/'> June 2020</option><option value='https://www.mpdigest.com/2020/05/'> May 2020</option><option value='https://www.mpdigest.com/2020/04/'> April 2020</option><option value='https://www.mpdigest.com/2020/03/'> March 2020</option><option value='https://www.mpdigest.com/2020/02/'> February 2020</option><option value='https://www.mpdigest.com/2020/01/'> January 2020</option><option value='https://www.mpdigest.com/2019/12/'> December 2019</option><option value='https://www.mpdigest.com/2019/11/'> November 2019</option><option value='https://www.mpdigest.com/2019/10/'> October 2019</option><option value='https://www.mpdigest.com/2019/09/'> September 2019</option><option value='https://www.mpdigest.com/2019/08/'> August 2019</option><option value='https://www.mpdigest.com/2019/07/'> July 2019</option><option value='https://www.mpdigest.com/2019/06/'> June 2019</option><option value='https://www.mpdigest.com/2019/05/'> May 2019</option><option value='https://www.mpdigest.com/2019/04/'> April 2019</option><option value='https://www.mpdigest.com/2019/03/'> March 2019</option><option value='https://www.mpdigest.com/2019/02/'> February 2019</option><option value='https://www.mpdigest.com/2019/01/'> January 2019</option><option value='https://www.mpdigest.com/2018/12/'> December 2018</option><option value='https://www.mpdigest.com/2018/11/'> November 2018</option><option value='https://www.mpdigest.com/2018/10/'> October 2018</option><option value='https://www.mpdigest.com/2018/09/'> September 2018</option><option value='https://www.mpdigest.com/2018/08/'> August 2018</option><option value='https://www.mpdigest.com/2018/07/'> July 2018</option><option value='https://www.mpdigest.com/2018/06/'> June 2018</option><option value='https://www.mpdigest.com/2018/05/'> May 2018</option><option value='https://www.mpdigest.com/2018/04/'> April 2018</option><option value='https://www.mpdigest.com/2018/03/'> March 2018</option><option value='https://www.mpdigest.com/2018/02/'> February 2018</option><option value='https://www.mpdigest.com/2018/01/'> January 2018</option><option value='https://www.mpdigest.com/2017/12/'> December 2017</option><option value='https://www.mpdigest.com/2017/11/'> November 2017</option><option value='https://www.mpdigest.com/2017/10/'> October 2017</option><option value='https://www.mpdigest.com/2017/09/'> September 2017</option><option value='https://www.mpdigest.com/2017/08/'> August 2017</option><option value='https://www.mpdigest.com/2017/07/'> July 2017</option><option value='https://www.mpdigest.com/2017/06/'> June 2017</option><option value='https://www.mpdigest.com/2017/05/'> May 2017</option><option value='https://www.mpdigest.com/2017/04/'> April 2017</option><option value='https://www.mpdigest.com/2017/03/'> March 2017</option><option value='https://www.mpdigest.com/2017/02/'> February 2017</option><option value='https://www.mpdigest.com/2017/01/'> January 2017</option><option value='https://www.mpdigest.com/2016/12/'> December 2016</option><option value='https://www.mpdigest.com/2016/11/'> November 2016</option><option value='https://www.mpdigest.com/2016/10/'> October 2016</option><option value='https://www.mpdigest.com/2016/09/'> September 2016</option><option value='https://www.mpdigest.com/2016/08/'> August 2016</option><option value='https://www.mpdigest.com/2016/07/'> July 2016</option><option value='https://www.mpdigest.com/2016/06/'> June 2016</option><option value='https://www.mpdigest.com/2016/05/'> May 2016</option><option value='https://www.mpdigest.com/2016/04/'> April 2016</option><option value='https://www.mpdigest.com/2016/03/'> March 2016</option><option value='https://www.mpdigest.com/2016/02/'> February 2016</option><option value='https://www.mpdigest.com/2016/01/'> January 2016</option><option value='https://www.mpdigest.com/2015/10/'> October 2015</option><option value='https://www.mpdigest.com/2015/09/'> September 2015</option><option value='https://www.mpdigest.com/2015/04/'> April 2015</option><option value='https://www.mpdigest.com/2014/10/'> October 2014</option><option value='https://www.mpdigest.com/2014/05/'> May 2014</option><option value='https://www.mpdigest.com/2013/06/'> June 2013</option> </select> <script type="text/javascript"> /* <![CDATA[ */
(function() {
 var dropdown = document.getElementById( "archives-dropdown-4" );
 function onSelectChange() {
 if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
 document.location.href = this.options[ this.selectedIndex ].value;
 }
 }
 dropdown.onchange = onSelectChange;
})();
/* ]]> */ </script></div></aside><aside id="black-studio-tinymce-9" class="widget col-md-3 module widget-col widget_black_studio_tinymce"><div class="widget-inner"><h2 class="widget-title h6">Privacy Policy</h2><div class="textwidget"><p>For our privacy policy please click <a style="color:#edc828;" href="https://www.mpdigest.com/contact-us/472-2/">here</a>.</p></div></div></aside><aside id="widget_wpmemwidget-2" class="widget col-md-3 module widget-col wp-members"><div class="widget-inner"><div id="wp-members"><h2 class="widget-title h6">Login Status</h2><form name="form" method="post" action="https://www.mpdigest.com/2021/09/27/rf-signal-chain-discourse-part-2-essential-building-blocks/"><fieldset><label for="username">Username or Email</label><div class="div_texbox"><input type="text" name="log" class="username" id="username" /></div><label for="password">Password</label><div class="div_texbox"><input type="password" name="pwd" class="password" id="password" /></div><input type="hidden" name="rememberme" value="forever" /><input type="hidden" name="redirect_to" value="https://www.mpdigest.com/2021/09/27/rf-signal-chain-discourse-part-2-essential-building-blocks/" /><input type="hidden" name="a" value="login" /><input type="hidden" name="slog" value="true" /><div class="button_div"><input type="submit" name="Submit" class="buttons" value="log in" /></div></fieldset></form></div></div></aside></div></div></div><!--.footer-sidebar--></div><!--.footer-inner--><div class="footer-info dark-div"><div class="container"><div class="row"><div class="col-md-6 col-sm-6 copyright font-1">© 2021 Octagon Communications</div><div class="col-md-6 col-sm-6 link font-1"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"></ul></div></div></div></div></div></footer></div><!--#wrap--> <!--Menu moblie--><div class="canvas-ovelay"></div><div id="off-canvas" class="off-canvas-default dark-div"><div class="off-canvas-inner"><div class="close-canvas-menu"> <i class="fa fa-times"></i> Close</div><nav class="off-menu"><ul><li id="menu-item-136" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-136"><a href="https://www.mpdigest.com/">Home</a></li><li id="menu-item-134" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-134"><a href="https://www.mpdigest.com/issues-supplements/">Issues &#038; Supplements</a></li><li id="menu-item-13935" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13935"><a href="https://www.mpdigest.com/podcast">MPD Podcasts</a></li><li id="menu-item-135" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-135"><a href="https://www.mpdigest.com/military-products/">Military Products</a></li><li id="menu-item-173" class="menu-item menu-item-type-taxonomy menu-item-object-tribe_events_cat menu-item-173"><a href="https://www.mpdigest.com/events/category/events/">Events</a></li><li id="menu-item-151" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151"><a target="_blank" rel="noopener" href="http://www.b2bmediaportal.com/register.aspx?fid=MPDCS">Subscribe</a></li><li id="menu-item-180" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children parent menu-item-180"><a href="#">Contact Us</a><ul class="sub-menu"><li id="menu-item-175" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-175"><a href="https://www.mpdigest.com/contact-us/">Contact Us</a></li><li id="menu-item-179" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-179"><a href="https://www.mpdigest.com/contact-us/about-us/">About Us</a></li><li id="menu-item-166" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-166"><a target="_blank" rel="noopener" href="https://www.mpdigest.com/wp-content/uploads/2021/02/Media_Kit_2_3_2021_MJ.pdf">Download Media Guide</a></li></ul></li><li id="menu-item-165" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children parent menu-item-165"><a href="#">Editorial</a><ul class="sub-menu"><li id="menu-item-162" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-162"><a href="https://www.mpdigest.com/editorial-calendar/">Editorial Calendar</a></li><li id="menu-item-153" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-153"><a href="https://www.mpdigest.com/article-submission-requirements/">Article Submission Requirements</a></li><li id="menu-item-156" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156"><a href="https://www.mpdigest.com/product-submission-requirements/">Product Submission Requirements</a></li></ul></li></ul><ul class="search-mobile-menu"><li><form action="https://www.mpdigest.com" method="get"> <input type="text" placeholder="Search..." name="s" value=""> <i class="fa fa-search"></i> <input type="submit" value="search"></form></li></ul></nav></div></div><!--Menu moblie--><div class="go-to-top"> <i class="fa fa-angle-up"></i></div><div class="popup_share_overlay"></div><div class="popup_share_video_wrapper"><div class="popup_share_video"><h4>Share this video</h4><ul class="social-listing list-inline change-color popup_share_video_listing"><li class="facebook"> <a class="trasition-all" title="Share on Facebook" href="#" target="_blank" rel="nofollow" onclick="window.open('https://www.facebook.com/sharer/sharer.php?u='+'https%3A%2F%2Fwww.mpdigest.com%2F2021%2F09%2F27%2Frf-signal-chain-discourse-part-2-essential-building-blocks%2F','facebook-share-dialog','width=626,height=436');return false;"><i class="fa fa-facebook"></i> </a></li><li class="twitter"> <a class="trasition-all" href="#" title="Share on Twitter" rel="nofollow" target="_blank" onclick="window.open('http://twitter.com/share?text=RF+Signal+Chain+Discourse+%E2%80%94+Part+2%3A+Essential+Building+Blocks&amp;url=https%3A%2F%2Fwww.mpdigest.com%2F2021%2F09%2F27%2Frf-signal-chain-discourse-part-2-essential-building-blocks%2F','twitter-share-dialog','width=626,height=436');return false;"><i class="fa fa-twitter"></i> </a></li><li class="linkedin"> <a class="trasition-all" href="#" title="Share on LinkedIn" rel="nofollow" target="_blank" onclick="window.open('http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Fwww.mpdigest.com%2F2021%2F09%2F27%2Frf-signal-chain-discourse-part-2-essential-building-blocks%2F&amp;title=RF+Signal+Chain+Discourse+%E2%80%94+Part+2%3A+Essential+Building+Blocks&amp;source=Microwave+Product+Digest','linkedin-share-dialog','width=626,height=436');return false;"><i class="fa fa-linkedin"></i> </a></li><li class="tumblr"> <a class="trasition-all" href="#" title="Share on Tumblr" rel="nofollow" target="_blank" onclick="window.open('http://www.tumblr.com/share/link?url=https%3A%2F%2Fwww.mpdigest.com%2F2021%2F09%2F27%2Frf-signal-chain-discourse-part-2-essential-building-blocks%2F&amp;name=RF+Signal+Chain+Discourse+%E2%80%94+Part+2%3A+Essential+Building+Blocks','tumblr-share-dialog','width=626,height=436');return false;"><i class="fa fa-tumblr"></i> </a></li><li class="google-plus"> <a class="trasition-all" href="#" title="Share on Google Plus" rel="nofollow" target="_blank" onclick="window.open('https://plus.google.com/share?url=https%3A%2F%2Fwww.mpdigest.com%2F2021%2F09%2F27%2Frf-signal-chain-discourse-part-2-essential-building-blocks%2F','googleplus-share-dialog','width=626,height=436');return false;"><i class="fa fa-google-plus"></i> </a></li><li class="pinterest"> <a class="trasition-all" href="#" title="Pin this" rel="nofollow" target="_blank" onclick="window.open('//pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.mpdigest.com%2F2021%2F09%2F27%2Frf-signal-chain-discourse-part-2-essential-building-blocks%2F&amp;media=&amp;description=RF+Signal+Chain+Discourse+%E2%80%94+Part+2%3A+Essential+Building+Blocks','pin-share-dialog','width=626,height=436');return false;"><i class="fa fa-pinterest"></i> </a></li><li class="vk"> <a class="trasition-all" href="#" title="Share on VK" rel="nofollow" target="_blank" onclick="window.open('//vkontakte.ru/share.php?url=https%3A%2F%2Fwww.mpdigest.com%2F2021%2F09%2F27%2Frf-signal-chain-discourse-part-2-essential-building-blocks%2F','vk-share-dialog','width=626,height=436');return false;"><i class="fa fa-vk"></i> </a></li><li class="email"> <a class="trasition-all" href="mailto:?subject=RF+Signal+Chain+Discourse+%E2%80%94+Part+2%3A+Essential+Building+Blocks&amp;body=https%3A%2F%2Fwww.mpdigest.com%2F2021%2F09%2F27%2Frf-signal-chain-discourse-part-2-essential-building-blocks%2F" title="Email this"><i class="fa fa-envelope"></i> </a></li></ul></div></div></div><!--#body-wrap--> <script> ( function ( body ) {
 'use strict';
 body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
 } )( document.body ); </script> <script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script> <script type='text/javascript' src='https://www.mpdigest.com/wp-content/plugins/newstube-shortcodes/shortcodes/library/touchswipe/jquery.touchSwipe.min.js' id='jquery-touchSwipe-js'></script> <script type='text/javascript' src='https://www.mpdigest.com/wp-content/uploads/siteground-optimizer-assets/ct-shortcode-js.min.js' id='ct-shortcode-js-js'></script> <script type='text/javascript' id='h5ab-print-js-js-extra'> /* <![CDATA[ */
var h5abPrintSettings = {"customCSS":""};
/* ]]> */ </script> <script type='text/javascript' src='https://www.mpdigest.com/wp-content/plugins/print-post-and-page/js/h5ab-print.min.js' id='h5ab-print-js-js'></script> <script type='text/javascript' id='jshowoff-adrotate-js-extra'> /* <![CDATA[ */
var impression_object = {"ajax_url":"https:\/\/www.mpdigest.com\/wp-admin\/admin-ajax.php"};
/* ]]> */ </script> <script type='text/javascript' src='https://www.mpdigest.com/wp-content/uploads/siteground-optimizer-assets/jshowoff-adrotate.min.js' id='jshowoff-adrotate-js'></script> <script type='text/javascript' id='clicktrack-adrotate-js-extra'> /* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/www.mpdigest.com\/wp-admin\/admin-ajax.php"};
/* ]]> */ </script> <script type='text/javascript' src='https://www.mpdigest.com/wp-content/uploads/siteground-optimizer-assets/clicktrack-adrotate.min.js' id='clicktrack-adrotate-js'></script> <script type='text/javascript' src='https://www.mpdigest.com/wp-content/uploads/siteground-optimizer-assets/fullscreen-lib.min.js' id='fullscreen-lib-js'></script> <script type='text/javascript' src='https://player.vimeo.com/api/player.js' id='vimeo-api-js'></script> <script type='text/javascript' src='https://www.mpdigest.com/wp-content/uploads/siteground-optimizer-assets/video-ads-management.min.js' id='video-ads-management-js'></script> <script type='text/javascript' src='https://www.mpdigest.com/wp-content/uploads/siteground-optimizer-assets/cactus-poll.min.js' id='cactus-poll-js'></script> <script type='text/javascript' src='https://www.google.com/recaptcha/api.js' id='cactus-poll-captcha-js'></script> <script type='text/javascript' src='https://www.mpdigest.com/wp-content/uploads/siteground-optimizer-assets/ct_rating-ajax.min.js' id='ct_rating-ajax-js'></script> <script type='text/javascript' src='https://www.mpdigest.com/wp-content/plugins/cactus-rating/js/wow.min.js' id='wow-js'></script> <script type='text/javascript' src='https://www.mpdigest.com/wp-content/uploads/siteground-optimizer-assets/raty.min.js' id='raty-js'></script> <script type='text/javascript' src='https://www.mpdigest.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js' id='regenerator-runtime-js'></script> <script type='text/javascript' src='https://www.mpdigest.com/wp-includes/js/dist/vendor/wp-polyfill.min.js' id='wp-polyfill-js'></script> <script type='text/javascript' id='contact-form-7-js-extra'> /* <![CDATA[ */
var wpcf7 = {"api":{"root":"https:\/\/www.mpdigest.com\/wp-json\/","namespace":"contact-form-7\/v1"}};
/* ]]> */ </script> <script type='text/javascript' src='https://www.mpdigest.com/wp-content/uploads/siteground-optimizer-assets/contact-form-7.min.js' id='contact-form-7-js'></script> <script type='text/javascript' id='mashmenu-js-js-extra'> /* <![CDATA[ */
var mashmenu = {"ajax_url":"https:\/\/www.mpdigest.com\/wp-admin\/admin-ajax.php","ajax_loader":"on","ajax_enabled":"0"};
/* ]]> */ </script> <script type='text/javascript' src='https://www.mpdigest.com/wp-content/uploads/siteground-optimizer-assets/mashmenu-js.min.js' id='mashmenu-js-js'></script> <script type='text/javascript' src='https://www.mpdigest.com/wp-content/themes/newstube/js/bootstrap.min.js' id='bootstrap-js'></script> <script type='text/javascript' src='https://www.mpdigest.com/wp-content/themes/newstube/js/swiper/swiper.jquery.min.js' id='swiper-js'></script> <script type='text/javascript' src='https://www.mpdigest.com/wp-includes/js/imagesloaded.min.js' id='imagesloaded-js'></script> <script type='text/javascript' src='https://www.mpdigest.com/wp-content/themes/newstube/js/malihu-scroll/jquery.mCustomScrollbar.concat.min.js' id='malihu-scroll-js'></script> <script type='text/javascript' src='https://www.mpdigest.com/wp-content/themes/newstube/js/jquery.ba-throttle-debounce.min.js' id='jquery.ba-throttle-debounce-js'></script> <script type='text/javascript' src='https://www.mpdigest.com/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script> <script type='text/javascript' src='https://www.mpdigest.com/wp-content/uploads/siteground-optimizer-assets/theme-js.min.js' id='theme-js-js'></script> <script type='text/javascript' src='https://www.mpdigest.com/wp-content/uploads/siteground-optimizer-assets/custom.min.js' id='custom-js'></script> <script type='text/javascript' src='https://www.mpdigest.com/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script> <script>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</script><!-- Global site tag (gtag.js) - Google Analytics --> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-72456674-1"></script> <script> window.dataLayer = window.dataLayer || [];
 function gtag(){dataLayer.push(arguments);}
 gtag('js', new Date());  gtag('config', 'UA-72456674-1'); </script><!-- AdRotate JS --> <script type="text/javascript"> jQuery(document).ready(function(){
if(jQuery.fn.gslider) {
 jQuery('.g-1').gslider({ groupid: 1, speed: 10000 });
 jQuery('.g-2').gslider({ groupid: 2, speed: 6000 });
 jQuery('.g-3').gslider({ groupid: 3, speed: 15000 });
 jQuery('.g-4').gslider({ groupid: 4, speed: 6000 });
}
}); </script> <!-- /AdRotate JS --> <script> jQuery( document ).ready( function($) {
 $('.bawpvc-ajax-counter').each( function( i ) {
 var $id = $(this).data('id');
 var t = this;
 var n = 1;
 $.get('https://www.mpdigest.com/wp-admin/admin-ajax.php?action=bawpvc-ajax-counter&p='+$id+'&n='+n, function( html ) {
 $(t).html( html );
 })
 });
}); </script></body></html>